Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

ACE Port redirection

Hi,

I am configuring load balancing for my web server which running on port 3636. But for users I want to give only http://172.23.15.87. not http://172.23.15.87:3636

Earlier I was having CSS in which I am able to achive this by creating two content rules one for the port 80 and one for port 3636. But here I dont know how to achieve it.

rserver MOSS_1
  ip address 192.168.200.38
inser
 
rserver MOSS_2
  ip address 192.168.200.40
inservice


serverfarm host SF_MYEM
  probe  PROBE_3636
rserver MOSS_1
inservice
  rserver MOSS_2
    inservice


sticky ip-netmask 255.255.255.255 address source SF_MYEM_STICK
  replicate sticky
  serverfarm SF_MYEM


class-map match-any MYEM
  2 match virtual-address 172.23.15.87 tcp eq 3636

policy-map type loadbalance first-match PM_LB_MYEM
  class class-default
    sticky-serverfarm SF_MYEM_STICK


policy-map multi-match PM_ENOC_Servers
  class MYEM
    loadbalance vip inservice
    loadbalance policy PM_LB_MYEM
    loadbalance vip icmp-reply active

Please let me know how to configure it so that users in the browser only put the VIP without the port 3636.

2 REPLIES
Bronze

Re: ACE Port redirection

Hello,

Just change the VIP to listen on www and set the port number right next to the rserver under the SF, like this

serverfarm host SF_MYEM

  probe  PROBE_3636

rserver MOSS_1 3636

inservice

  rserver MOSS_2 3636

    inservice

class-map match-any MYEM

  2 match virtual-address 172.23.15.87 tcp eq www

Make sure you remove the rservers from the SF before you applied the change otherwise you'll end up with 4 rservers listening on different port under the same serverfarm.

HTH

__ __

Pablo

Community Member

ACE Port redirection

Hi,

I have tried the configuration but only port 80 is working I am not able to open the page

on port 3636.

rserver host MOSS_1
  ip address 192.168.200.38
  inservice
rserver host MOSS_2
  ip address 192.168.200.40
  inservice


serverfarm host SF_EM
  probe PROBE_3636
  rserver MOSS_1 3636
    inservice
  rserver MOSS_2 3636
    inservice

serverfarm host SF_MY
  probe PROBE_TCP
  rserver MOSS_1
    inservice
  rserver MOSS_2
    inservice

sticky ip-netmask 255.255.255.255 address source SF_MY_STICK
  replicate sticky
  serverfarm SF_MY


sticky ip-netmask 255.255.255.255 address source SF_MYEM_STICK
  replicate sticky
  serverfarm SF_MYEM

class-map match-any MYEM
  3 match virtual-address 172.23.15.87 tcp eq www


class-map match-any MY
  2 match virtual-address 172.23.15.86 tcp eq www

policy-map type loadbalance first-match PM_LB_MYEM
  class class-default
    sticky-serverfarm SF_MYEM_STICK

policy-map type loadbalance first-match PM_LB_MY
  class class-default
    sticky-serverfarm SF_MY_STICK


policy-map multi-match PM_ENOC_Servers

class MYEM
    loadbalance vip inservice
    loadbalance policy PM_LB_MYENOC
    loadbalance vip icmp-reply active

class MY
    loadbalance vip inservice
    loadbalance policy PM_LB_MYENOC
    loadbalance vip icmp-reply active

interface vlan 200

service-policy input PM_ENOC_Servers

I can ping the VIP and I can telnet on port 3636 successfully. But Web page is not showing for port 3636 but the website on port 80 is working fine.

Please assist me what I am missing.

539
Views
4
Helpful
2
Replies
CreatePlease to create content