Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

ACE's mac-sticky equivalent on CSS

Been working only on ACE equipment and now I have to solve a mac sticky problem, but on a CSS instead.

mac-sticky is enabled on a vlan interface on an ACE in bridged mode, it make sure that all traffic sourced on that interface is destined back through the same interface.

My question is how would I solve this with CSS if you could paste a sample config It would be greatly appreciated!

//tyrone

3 REPLIES
Cisco Employee

Re: ACE's mac-sticky equivalent on CSS

Not really an equivalent but the following command is often required on the CSS when configured in bridge mode.

CSS11503-2(config)# ip uncond-bridging

This tells the CSS to first bridge and only route if needed.

Gilles.

New Member

Re: ACE's mac-sticky equivalent on CSS

Hi this didn't help me in my quest,

How can I allow the return traffic to come through the same interface? if I add an ip route 0.0.0.0 0.0.0.0 194.132.xxx.236 my setup works fine but the other subnets are affected obiviously because there is 2 default route configured

How can I get around this?

I have the following:

ip route 0.0.0.0 0.0.0.0 194.132.xxx.222 1

************************* INTERFACE *************************

interface e1

phy 100Mbits-FD

bridge vlan 30

interface e2

bridge vlan 92

phy 100Mbits-FD

interface e3

phy 100Mbits-FD

bridge vlan 70

interface e4

phy 100Mbits-FD

admin-shutdown

interface e5

phy 100Mbits-FD

bridge vlan 15

interface e6

admin-shutdown

interface e7

admin-shutdown

bridge vlan 11

interface e8

phy 100Mbits-FD

bridge vlan 11

!************************** CIRCUIT **************************

circuit VLAN30

redundancy

ip address 194.132.xxx.68 255.255.255.224

circuit VLAN92

redundancy

ip address 192.168.xxx.1 255.255.255.0

circuit VLAN70

redundancy

ip address 194.132.xxx.218 255.255.255.224

no redirects

circuit VLAN11

ip address 192.168.99.85 255.255.255.252

redundancy-protocol

circuit VLAN15

redundancy

ip address 194.132.xxx.226 255.255.255.240

Cisco Employee

Re: ACE's mac-sticky equivalent on CSS

there is no mac-sticky equivalent on the CSS.

The only thing you can control is ecmp.

http://www.cisco.com/en/US/docs/app_ntwk_services/data_center_app_services/css11500series/v7.20/configuration/administration/guide/Protocol.html

"By default, the ingress path for a flow is the preferred egress path. This means that the preferred interface over which to reply to a client is the interface on which the CSS originally received the request from the client. "

For this to work, you need to add this 2nd route.

Gilles.

336
Views
4
Helpful
3
Replies