Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

ACE Startup-config file location


I was reading the ACE docs and it sounds like the startup-config file should be listed under disk0: but I don't see it there. Can someone point out where the startup-config file is.




Re: ACE Startup-config file location


Upon startup, the ACE loads the startup-configuration file stored in Flash memory (nonvolatile memory) to the running-configuration file stored in RAM (volatile memory). When you partition your ACE into multiple contexts, each context contains its own startup-configuration file.

Flash memory stores the startup-configuration files for each existing context. When you create a new context, the ACE creates a new context directory in Flash memory to store the context-specific startup-configuration files. When you copy a configuration file from the ACE, you create a copy of the configuration information of the context from where you executed the command.

To display the directory contents of a specified file system, use the dir command in Exec mode. This command displays a detailed list of directories and files contained within the specified file system on the ACE, including names, sizes, and time created. You may optionally specify the name of a directory to list.

The syntax for this command is:

dir {core: | disk0:[directory/][filename] | image:[filename] | probe:[filename] | volatile:[filename]}

The keywords and arguments are:

•core:-Displays the contents of the core: file system.

•disk0:-Displays the contents of the disk0: file system.

•image:-Displays the contents of the image: file system.

•probe:-Displays the contents of the probe: file system. This directory contains the Cisco-supplied scripts. For more information about these scripts, see the Cisco 4700 Series Application Control Engine Appliance Server Load-Balancing Configuration Guide.

•volatile:-Displays the contents of the volatile: file system.

•directory/-(Optional) Contents of the specified directory.

•filename-(Optional) Information that relates to the specified file, such as the file size and the date it was created. You can use wildcards in the filename. A wildcard character (*) matches all patterns. Strings after a wildcard are ignored.

For example, to list the files in the disk0: file system, enter:

host1/Admin# dir disk0:

host/Admin# dir disk0:

7465 Jan 03 00:13:22 2007 C2_dsb

2218 Mar 07 18:38:03 2007 ECHO_PROBE_SCRIPT4

1024 Feb 16 12:47:24 2007 core_copies_dsb/

1024 Jan 01 00:02:07 2007 cv/

1024 Mar 13 13:53:08 2007 dsb_dir/

12 Jan 30 17:54:26 2007 messages

7843 Mar 09 22:19:56 2007 running-config

4320 Jan 05 14:37:52 2007 startup-config

1024 Jan 01 00:02:28 2007 www/

Usage for disk0: filesystem

4254720 bytes total used

6909952 bytes free

For example, to list the core dump files in Flash memory, enter:

host1/Admin# dir core:

253151 Mar 14 21:23:33 2007 0x401_vsh_log.8249.tar.gz

262711 Mar 15 21:22:18 2007 0x401_vsh_log.15592.tar.gz

250037 Mar 15 18:35:27 2007 0x401_vsh_log.16296.tar.gz

Usage for core: filesystem

1847296 bytes total used

64142336 bytes free

65989632 bytes available

New Member

Re: ACE Startup-config file location


Thanks for the info.

When I run dir disk0: I don't see my startup-config file. Is that where it should be?


Re: ACE Startup-config file location

are you in admin context or some other context.

Kindly tell.

New Member

Re: ACE Startup-config file location

I've tried it from all contexts. Admin and others.

New Member

ACE Startup-config file location


Did you ever find the startup config?




ACE Startup-config file location

The ACE has a number of compressed filesystems held in an internal filesystem to house startup configuratiom, PKI objects, audit logs and core dumps and other objects. If you need access to them, then you need to load a debug plug-in available from TAC.