Cisco Support Community
Community Member

ACE with SSO

Hello Everyone,

Does anyone know if ACE requires special setting to work with SSO enabled sites?

When I try to open SSO enabled sites , I get to the correct login page but when I enter credentials, it gives me error 404.

Experiencing similar issue with SAP ESS application where SSO authentication is not happening and users are asked for double authentication.

I have tried disabling tcp server conection reuse in parametere map......Is there anything else to solve the issue with SSO?

Thanks in Advance



ACE with SSO

Nishchay, Probably best to open a tac case to troubleshoot the issue. It should be able to work (it is working at other customers). My guess is that you might have sticky issues. Matthew

Community Member

ACE with SSO

We have it working, but one of the things we had to do what to increase the header-maxparse-lenght.  We are using http-cookie sticky, parameter-map with header-maxparse-length of 14000, persistence-rebalance and we re-encrypt everything going back to the serverfarm this seems to work fine


ACE with SSO

Hi Nishchay,

Please send the running-config of the ACE to review it, let me know the VIP address with the problem.

404 is NOT FOUND, it could be a stickiness issue.

--------------------- Cesar R ANS Team
Community Member

ACE with SSO


I have single server in serverfarm so sticky is not configured.

User connects to SAP server (front end server) which then gets data from backend servers for various applications.

Issue exists for single application (out of around 10 app) where during my last migration from CSS to ACE, it worked in the begining but then suddenly some users started facing issue error 404: requested resource does not exist.

When it was reverted to CSS, it started working again. Even when it was reverted, application was still working for some users. Issue was really strange and could not do much troubleshooting as connection to server was ok and all applications were working. These all are SAP applications...

Community Member

ACE with SSO

users are getting below error

404: not found    

requested resource does not exist


ACE with SSO

You'll probably need to open a tac case so someone can check the css & tac configs and you'll probably need to get concurrent traces either side of the ace (and maybe css for comparison). Are both css and ace configured for the same behaviour. I had a ticket recently where the css was configured for http and https to forward to the rserver, the ace rediected http to https and the browser re-acted differently. Matthew

ACE with SSO


Can you paste the CSS configuration and ACE configuration?


CreatePlease to create content