Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

ACE20 - Loadbalancing across 3 virtual servers sharing the same address

I have 3 virtual servers sharing the same IP, just using different ports.

192.168.1.1:8000 = server1

192.168.1.1:8001 = server2

192.168.1.1:8002 = server3

I would like to loadbalance across all 3 with the following probe, looking for the URL.

http://192.168.1.1:8000/index.php

http://192.168.1.1:8001/index.php

http://192.168.1.1:8002/index.php

The config I have in place doesn't seem to be working...  I probably configured this entirely wrong... not sure.

I need to understand what I missed.

++++++++++++++++++++++++++++++++++++++++++++++++++++++

probe http WEB1-http-probe

   interval 30

   passdetect interval 5

   request method get url /index.php

   expect status 200 200

   connection term forced

probe http WEB2-http-probe

   interval 30

   passdetect interval 5

   request method get url /index.php

   expect status 200 200

   connection term forced

probe http WEB3-http-probe

   interval 30

   passdetect interval 5

   request method get url /index.php

   expect status 200 200

   connection term forced

! RSERVER

rserver host 192.168.1.1-rs

   ip address 192.168.1.1

   inservice

! SERVERFARM

serverfarm host WEB-sf-HTTP

   rserver  192.168.1.1-rs 8000

      probe WEB1-http-probe

      inservice

   rserver  192.168.1.1-rs 8001

      probe WEB2-http-probe

      inservice

   rserver  192.168.1.1-rs 8002

      probe WEB3-http-probe

      inservice

! STICKYGROUP

sticky ip-netmask 255.255.255.255 address source StickyGroup_WEB-HTTP

   timeout 60

   replicate sticky

   serverfarm WEB-sf-HTTP

! CLASS-MAP

class-map match-any WEB-cm-HTTP

    2 match virtual-address 192.168.200.1 tcp eq 80

! POLICY-MAP

policy-map type loadbalance first-match WEB-pm-HTTP

  class class-default

    serverfarm WEB-sf-HTTP

policy-map multi-match POLICY

   class WEB-cm-HTTP

     loadbalance vip inservice

     loadbalance policy WEB-pm-HTTP

     loadbalance vip icmp-reply active

-------------------------------------------------------------------------------------------------

When I check the status of the RSERVER, the probes all indicate "FAIL"

Everyone's tags (1)
1 REPLY
Community Member

ACE20 - Loadbalancing across 3 virtual servers sharing the same

Found my problem...

I failed to put in the "port" statement under the probe.

After doing this and then verifying the RSERVER status, all the probes now show as OPERATIONAL.

!

probe http WEB1-http-probe

port 8000

!

351
Views
0
Helpful
1
Replies
CreatePlease to create content