Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Balance generic service

Hi

I am working on the configuration of a 11503, I have the http side working fine but having trouble finding any details on how to balance the ldap service.

The services show as being up, and the keepalives work. But I must be missing something.

Any help would be appreciated.

Thanks

Andrew

service LDAP_STAFF01

ip address x.x.85.33

keepalive port 389

keepalive type script ap-kal-ldap "x.x.85.33"

active

service LDAP_STAFF02

ip address x.x.85.121

keepalive port 389

keepalive type script ap-kal-ldap "x.x.85.121"

active

owner BLACKBOARD_PRODUCTION

content LDAP_STAFF

url "/*"

protocol tcp

port 389

balance leastconn

vip address x.x.86.227

add service LDAP_STAFF01

add service LDAP_STAFF02

active

6 REPLIES
New Member

Re: Balance generic service

Does it work better if you remove the url "/*" command in the content block?

New Member

Re: Balance generic service

I have tried it with or without and it makes no difference.

Eventually I would like to balance two DB servers as well, but have to sort out how to get this one working.

New Member

Re: Balance generic service

Andrew,

The URL command only has effect for web services, so it can be removed.

Are the users of the LDAP VIP in the same subnet as the services (your x.x.86 subnet)? If so, the servers are replying directly to the user, bypassing the CSS in the response. To fix this, either make the CSS default gateway for the services, or add "group" to the config, give it a vip address, then add services to it, activate, test again.

Peter

New Member

Re: Balance generic service

The clients are on the same subnet, ldap servers on different subnet. I have tried some with the default gateway configured to the CSS and some connected directly into the content switch.

Even tried setting up a group and still no luck.

New Member

Re: Balance generic service

-

New Member

Re: Balance generic service

Hi there,

Did you ever get proper ldap load balancing working with the CSS? I'm having a similar issue and I sure would appreciate to pick your brain.

142
Views
0
Helpful
6
Replies
CreatePlease to create content