Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Basic transparent caching questions:

Hi,

I am attempting to perform web caching with one 7325 that has two interfaces connected to two different VLAN's on the same 6500. Although I currently have this working, I ran into lots of problems getting it to work and don't really have a good reason why it wasn't working for most of the day. Therefore, I would like to cover some basics first (since I'm a beginner CDN'er.)

1) Is it possible to dual-home a CE via two different network connections?

2) Do I have to specify any/all interfaces of the 6500 in my CE router list if all of the interfaces are on the same CE? Note: "show ip wccp" on the 6500 does show that the CE has been contacted and redirects are ocurring.

3) the "router id" that wccp uses is actually my router-id specified in my OSPF commands of the 6500. Does this create a problem with the fact that this address is not specified in my router list?

Below are the highlights of the WCCP router and CE config. Thanks for any advice.

ROUTER:

ip wccp web-cache redirect-list 100

access-list 100 deny ip any 128.228.0.0 0.0.255.255

access-list 100 permit tcp any any eq www

interface Vlan144

ip address 199.219.144.3 255.255.255.0

no ip unreachables

ip wccp web-cache redirect out

ip route-cache same-interface

!

interface Vlan145

description STUDENTBACKBONE

ip address 10.10.2.1 255.255.255.0

ip wccp web-cache redirect out

ip route-cache same-interface

!

CE:

interface GigabitEthernet 1/0

ip address 10.10.2.225 255.255.255.0

exit

interface GigabitEthernet 2/0

ip address 199.219.144.225 255.255.255.0

exit

!

!

wccp router-list 1 10.10.2.1 199.219.144.3

wccp web-cache router-list-num 1 l2-redirect

wccp version 2

!

2 REPLIES
Cisco Employee

Re: Basic transparent caching questions:

1/ is ok

2/ the wccp router-list should contain at least 1 ip address of the router.

I never no by heart if this is the router-id or the physical interface ip that we have to use, so I usually configure both.

3/ the router-id has no significance except identifying the different routers if there are more than one.

Whatever ip being used is ok so we usually do not pay too much attention to it.

Regarding the config, I don't see why you have redirect out configured on vlan 145.

Are there any web servers on this vlan ?

And if so, do you really need to intercept the traffic ?

I would remove this command from this interface.

Gilles.

New Member

Re: Basic transparent caching questions:

Giles,

Thanks for input. The deal with VLAN 145 opens "Pandora's box". The customer has a PIX which only NAT's private addresses before they go to the internet PIX. This NAT PIX has its inside interface on VLAN 145 (route map statements aren't shown in config) and its outside interface on VLAN 144. VLAN 144 also has the inside interface of the internet PIX. The reason why I redirected on VLAN 144 was that I figured an ICMP redirect would be sent to the NAT PIX telling him the best hop to get to the internet was the INTERNET PIX inside address and; therefore, the WCCP redirect on VLAN 144 would only catch web-cache stuff for public addressed clients. Its pretty ugly and I think plays into some of my problems.

Last night from furstration with lack of consistent operability, I changed the two CE uplinks to ether-channel and addressed it with 199.219.144.225. I kept all the WCCP info the same and internet access/caching worked the very first time.

Thanks again for the input on my config Giles.

Mike.

165
Views
0
Helpful
2
Replies
CreatePlease login to create content