Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Silver

Cannot telnet the virtual server address, but can ping it

CSM card on Cat6500 switch

VLAN 310 has the server connected directly. VLAN 253 is the client side. Only one real server in the server farm(for testing).

My problem is the clients can ping the virtual address 132.253.253.238, but they cannot telnet or ftp innto the server. The telnet, ftp services are running in the server and are verified. Checking with analyzer it was found that the client send TCP_SYN to the virtual server, but the virtual server donot reply with a SYN_ACK.

I have the command virtual 132.253.253.238 tcp 0, which means that all tcp ports are allowed. I also tried with specific port like 23 for telnet, but same issue.

Can anybody help me on this??

ip slb mode csm

ip slb vlan 253 client

ip address 132.253.253.237 255.255.255.0

gateway 132.253.253.1

!

ip slb vlan 310 server

ip address 172.16.100.5 255.255.255.0

!

ip slb serverfarm DNSFARM

real 172.16.100.10

inservice

!

ip slb vserver DNSSERVER

virtual 132.253.253.238 tcp 0

serverfarm DNSFARM

inservice

!

interface Vlan253

ip address 132.253.253.171 255.255.255.0

!

interface FastEthernet3/1

no ip address

switchport

switchport access vlan 310

!

interface FastEthernet3/2

no ip address

switchport

switchport access vlan 253

!

1 REPLY
New Member

Re: Cannot telnet the virtual server address, but can ping it

It looks like you need an "alias IP address" on the server vlan. The CSM needs the address you already have there to route packets internally on the backplane. It also needs another one that the servers can use for a default gateway.

cat(config-slb-vlan-server)#alias 172.16.100.1 255.255.255.0

Check out the following Tech Tip.....If you have a minute, we would also like your feedback on it so we can improve it. There is a form on the right side where you can rate it.

http://www.cisco.com/warp/customer/117/csm/csm_router.html

Hope this helps,

Steve Hall

206
Views
0
Helpful
1
Replies
CreatePlease to create content