Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Cisco ACE 4710 Configuration Assistance for new entry

                   Hello

Thank you experts for your valuable time and advice.

I have inherited a running LB with  configuration.

There are two phyiscal servers 10.17.2.14 & 10.17.2.15 with VIP 10.17.0.12 configured on it.

I am a newbie to Cisco ACE and i want to add two physical  servers 10.17.2.113 and 10.17.2.114 with virtual ip 10.17.0.112.

I can see that what i need to do for the new setup is similiar to the existing one as the two new servers are also Microsoft exchange servers , but  i am bit confused in some parts .

This is my current config

ccess-list ALL line 8 extended permit ip any any

probe tcp HUB_CAS_TCP_80
  port 80
  interval 2
  passdetect interval 5
  receive 1

rserver host HC01-MBZ.iat.ac.ae
  ip address 10.17.2.14
  inservice
rserver host HC02-MBZ.iat.ac.ae
  ip address 10.17.2.15
  inservice

serverfarm host Hub-Cas-Sfarm
  failaction purge
  predictor leastconns
  probe HUB_CAS_TCP_80
  rserver HC01-MBZ.efg.com
    inservice
  rserver HC02-MBZ.efg.com
    inservice

sticky ip-netmask 255.255.255.255 address source HUB-CAS-STICKY
  timeout activeconns
  replicate sticky
  serverfarm Hub-Cas-Sfarm


class-map match-any Hub-Cas_VIP
  2 match virtual-address 10.17.0.12 any
class-map type management match-any remote_access
  2 match protocol xml-https any
  3 match protocol icmp any
  4 match protocol telnet any
  5 match protocol ssh any
  6 match protocol http any
  7 match protocol https any
  8 match protocol snmp any

policy-map type management first-match remote_mgmt_allow_policy
  class remote_access
    permit

policy-map type loadbalance first-match HUB-CAS_POLICY_MAP_80
  class class-default
    sticky-serverfarm HUB-CAS-STICKY

policy-map multi-match HUB-CAS_SLB_80
  class Hub-Cas_VIP
    loadbalance vip inservice
    loadbalance policy HUB-CAS_POLICY_MAP_80
    loadbalance vip icmp-reply
    nat dynamic 1 vlan 99

interface vlan 99
  ip address 10.17.0.24 255.255.255.0
  no normalization
  no icmp-guard
  access-group input ALL
  nat-pool 1 10.17.0.13 10.17.0.13 netmask 255.255.255.0 pat
  service-policy input remote_mgmt_allow_policy
  service-policy input HUB-CAS_SLB_80
  no shutdown
interface vlan 496
  ip address 10.17.196.4 255.255.255.0
  access-group input ALL
  service-policy input remote_mgmt_allow_policy
  service-policy input HUB-CAS_SLB_80
  no shutdown

ip route 0.0.0.0 0.0.0.0 10.17.0.1

Appreciate your kind assistance as I am a newbie to Cisco ACE and i want to add two physical servers 10.17.2.113 and 10.17.2.114 with virtual ip 10.17.0.112 similiar to above.

Based on the above , i understand i need to do the following

Create the two Real Physical Servers

--------------------------------------------

---------------------------------------------

rserver host A-hub-cas-1
ip address 10.17.2.113

inservice


rserver host A-hub-cas-2
ip address 10.17.2.114

inservice

Create a New Serverfarm

----------------------------------------------------

----------------------------------------------------

serverfarm host A-Hub-Cas-Sfarm

  failaction purge

  predictor leastconns

  probe HUB_CAS_TCP_80   [ Can I use the same Probe as used earlier in my current running  config  or i have to create a new one . The need is same as probe HUB_CAS_TCP_80 ]

   rserver  A-hub-cas-1.com [ Above domain is efg.com and the now i am using abc.com .]

    inservice

  rserver  A-hub-cas-2.com

inservice

Create a class map to define the VIP to which inside or outside users will send their requests

--------------------------------------------------------------------------------------------------------------------------------------------

--------------------------------------------------------------------------------------------------------------------------------------------

class-map match-any T_Hub-Cas_VIP
2 match virtual-address 10.17.0.112 any

The rest i am confused

I see that above there are some sticky parameters and as well as some service policy applied as well as policy matches

Appreciate your kind help in completing my configuration.

Thanks

1 ACCEPTED SOLUTION

Accepted Solutions
Bronze

Cisco ACE 4710 Configuration Assistance for new entry

Hello,

  You can reuse the same probes and policy map multi-match for the configuration additions.

  Here is what I would do at this point:

1.) Create a new sticky group:

sticky ip-netmask 255.255.255.255 address source A_HUB-CAS-STICKY

timeout activeconns

replicate sticky

serverfarm A-Hub-Cas-Sfarm

2.) Add a policymap type loadbalance:

policy-map type loadbalance first-match A_HUB-CAS_POLICY_MAP_80

class class-default

sticky-serverfarm A_HUB-CAS-STICKY

3.) Add the rest of the configuration to the existing policymap multi match:

policy-map multi-match HUB-CAS_SLB_80

class T_Hub-Cas_VIP

loadbalance vip inservice

loadbalance policy A_HUB-CAS_POLICY_MAP_80

loadbalance vip icmp-reply

nat dynamic 1 vlan

That sould do it.

Regards,

Chris Higgins

2 REPLIES
Bronze

Cisco ACE 4710 Configuration Assistance for new entry

Hello,

  You can reuse the same probes and policy map multi-match for the configuration additions.

  Here is what I would do at this point:

1.) Create a new sticky group:

sticky ip-netmask 255.255.255.255 address source A_HUB-CAS-STICKY

timeout activeconns

replicate sticky

serverfarm A-Hub-Cas-Sfarm

2.) Add a policymap type loadbalance:

policy-map type loadbalance first-match A_HUB-CAS_POLICY_MAP_80

class class-default

sticky-serverfarm A_HUB-CAS-STICKY

3.) Add the rest of the configuration to the existing policymap multi match:

policy-map multi-match HUB-CAS_SLB_80

class T_Hub-Cas_VIP

loadbalance vip inservice

loadbalance policy A_HUB-CAS_POLICY_MAP_80

loadbalance vip icmp-reply

nat dynamic 1 vlan

That sould do it.

Regards,

Chris Higgins

New Member

Cisco ACE 4710 Configuration Assistance for new entry

Thanks Christopher

It is working fine

596
Views
0
Helpful
2
Replies