Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Configuring Sticky TCP Connections on ACE

I have 6 ACE configuration guides/case study example configurations and all have a slightly different way of configuring sticky connections in the admin context. What is the right way to configure it?

Thanks!

Matt

1 REPLY

Re: Configuring Sticky TCP Connections on ACE

Here is the 7th config :)

You didnt mention which persistence method you are interested in. Following is an example for source ip based stickiness

rserver host APP1-SERVER1

ip address 10.10.10.101

inservice

rserver host APP1-SERVER2

ip address 10.10.10.102

inservice

serverfarm host APP1-SFARM

probe http80

predictor leastconn

failaction purge

rserver APP1-SERVER1

inservice

rserver APP1-SERVER 2

inservice

Sticky ip-netmask 255.255.255.255 address source APP1-STICKY-GP

timeout 60

replicate sticky

server-farm APP1-SFARM

class-map match-any APP1-VIP-CLASS

description class-map for APP1

match virtual-address 192.168.0.100 tcp eq 80

policy-map type loadbalance first-match APP1-POLICY

class class-default

sticky-serverfarm APP1-STICKY-GP

policy-map multi-match VIPS

class APP1-VIP-CLASS

loadbalance vip inservice

loadbalance policy APP1-POLICY

loadbalance vip icmp-reply

interface vlan 20

ip address 192.168.0.1 255.255.255.0

access-group input anyone

access-group output anyone

service-policy input VIPS

no shutdown

HTH

Syed Iftekhar Ahmed

215
Views
5
Helpful
1
Replies