Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

conn reuse doesn't work in A5(1.0)

Hi,

I configured conn reuse and I tried to provide requests from diferent clients to the VIP address (172.16.11.150). The ACE provides load-balancing, but it doesn't provide conn reuse. The server uses the same MSS as ACE (1460). See the configuration bellow:

ACE-4710-1/Lab-OPT-11# sho run
Generating configuration....

access-list traffic line 8 extended permit ip any any

rserver host s1
  ip address 192.168.1.21
  inservice
rserver host s2
  ip address 192.168.1.22
  inservice

serverfarm host WEB
  rserver s1
    inservice
  rserver s2
    inservice

parameter-map type http REUSE
  server-conn reuse
  persistence-rebalance


class-map match-all VIP
  3 match virtual-address 172.16.11.150 tcp eq www
policy-map type loadbalance first-match test
  class class-default
    serverfarm WEB

policy-map multi-match CL
  class VIP
    loadbalance vip inservice
    loadbalance policy test
    loadbalance vip icmp-reply
    nat dynamic 1 vlan 341
    appl-parameter http advanced-options REUSE

interface vlan 341
  description Server vlan
  ip address 192.168.1.1 255.255.255.0
  nat-pool 1 192.168.1.100 192.168.1.100 netmask 255.255.255.255 pat
  no shutdown
interface vlan 345
  ip address 172.16.11.2 255.255.255.0
  access-group input traffic

  service-policy input CL
  no shutdown

There are some outputs from show commands on ACE:

ACE-4710-1/Lab-OPT-11# sho serverfarm WEB

serverfarm     : WEB, type: HOST
total rservers : 2
state          : ACTIVE
DWS state      : DISABLED
---------------------------------
                                                ----------connections-----------
       real                  weight state        current    total      failures
   ---+---------------------+------+------------+----------+----------+---------
   rserver: s1
       192.168.1.21:0        8   OPERATIONAL     0          23         0
   rserver: s2
       192.168.1.22:0        8   OPERATIONAL     0          22         0

ACE-4710-1/Lab-OPT-11# sho stats http | inc Reuse

Reuse msgs sent           : 0          , HTTP requests            : 419

ACE-4710-1/Lab-OPT-11# show np 1 me-stats "-socm -v" | i [uU][sS][eE]

Reuse retrieve link update conn invalid           0             0

Reuse retrieve link update conn not on r          0             0

Reuse retrieve success but conn invalid:          0             0

Reuse retrieve miss:                              0             0

Reuse conns retrieved:                            0             0

Can you help me? Do I have some mistake in configuration?

Thank you

Roman

Everyone's tags (2)
1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

conn reuse doesn't work in A5(1.0)

Hi Roman,

Connection reuse only makes sense in a L7 environment, in which the ACE proxies the client connection, but you configured your VIP as a L4 one. In that situation, connection reused will not be used at all.

Can you please try changing your VIP to a L7 configuration (by adding a URL match class-map) and see if connection reuse starts to work?

Daniel

2 REPLIES
Cisco Employee

conn reuse doesn't work in A5(1.0)

Hi Roman,

Connection reuse only makes sense in a L7 environment, in which the ACE proxies the client connection, but you configured your VIP as a L4 one. In that situation, connection reused will not be used at all.

Can you please try changing your VIP to a L7 configuration (by adding a URL match class-map) and see if connection reuse starts to work?

Daniel

Community Member

conn reuse doesn't work in A5(1.0)

Hi Daniel,

you are right. I configured L7 rule and for now it is working well. Thank you for your help!!

Roman

457
Views
0
Helpful
2
Replies
CreatePlease to create content