Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

CSM sendmail script

Hi

Am trying to set up the CSM to send SMTP mail when a probe fails but it doesn't seem to be working at all. I have tried the example script but this does not work in our environment, even if I do put in the EHLO that is required.

Basically I think the problem is that the CSM is sending information too quickly and not waiting for the server to reply. Using gets $sock gets 1 line of information back, but the mail server sends something like 15 lines back with the initial EHLO and if you send it information too quickly the server does not actually send the mail. This behaviour can be duplicated by copy/paste into a telnet session with the server.

I have tried various options but, of course, the server doesn't send back an EOF or any other obvious prompt and gets just waits and doesn't return if there is no more data coming.

Does anybody have a working sendmail script that I could look at for enlightenment, or is there a way to have the CSM perform a time-based interrupt or pause/sleep cycle? I have looked at vwait and after but these don't seem to be implemented on the CSM.

Any ideas welcomed at this stage. Version of code on CSM is 4.2(1)

Thanks

LP

2 REPLIES
Silver

Re: CSM sendmail script

Bad installation, it means that the whole gateway (or most files) are running version X but a few (but important files, including the MPNotify.exe itself) was running version Y. Because of this mismatch, it cause the problem to surface.

New Member

Re: CSM sendmail script

Huh? Was this answering a different question?

123
Views
0
Helpful
2
Replies