Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

CSS 11506 - SCM CPU load

Hello,

we have about 30 CSS Devices, mostly 11503.

But we have also 4 11506 in our Network.

On These 4 CSS Devices, we se much highter CPU Load on the SCM CPU, we are monitoring.

Since we did a softwareupgrade from 5.20 Build 6 to 7.20 Build 109 we se much highter CPU Load on these Devices.

Serval times, there are peaks at 100% CPU Utilisation. The duration from those peaks vary, up to 2 hours.

The peaks are independet from traffic. Also our IOMs are only loaded at max 10% CPU Util.

Any idea, what this could be?

On Our 11503 Devices, the Peaks are not over 50% Utilisation on the SCM. Mostly they are at 20%.

Best Regards

3 REPLIES
Cisco Employee

Re: CSS 11506 - SCM CPU load

At the time of the problem, you can do from debug mode :

GILLES(debug)# cpu hog 1 1

CPU Hog Debug Options (1/1)

d) Display data

Please enter selection [q=Quit]:d

Checking CPU Hog

TID Name Milliseconds

--- ---- ------------

0x8c462d70 apIdle 2

0x8e24aea0 tNetTask 1

0x8a6a00a0 AS_0000012b.I 1

0x8df80bf0 SysTimerHandler 1

0x8bce05d0 tFlowMgrPktRx 1

Do this many times to see if this is always the same process consuming the cpu.

Reason for high cpu could be logging level set to debugging (make sure it is set to level 4), too many

scripted keepalives, ...

Another possible reason is this bug :

CSCec83724

Source Group Portmappings decrease with # of modules and ASR

If you have ASR configured and source group, you may run out of ports so the CSS will loop looking for a free a port.

Regards,

Gilles.

New Member

Re: CSS 11506 - SCM CPU load

Hello Gilles,

thanks for your reply, but i did not get an idea whats the reason, by using the CPU hog.

I always get output like this:

Checking CPU Hog

TID Name Milliseconds

--- ---- ------------

0x8a39afe0 tSyncReq 0

0x8dfc7150 ImmGetAgent 0

0x8a412b20 AS_00001786.I 0

0x8c44fa70 apIdle 0

0x8bccd2d0 tFlowMgrPktRx 0

Checking SemID = 0x00000000

TID Name sem MilliSecs

--- ---- -------------

Checking SemID = 0x00000000

TID Name sem MilliSecs

--- ---- -------------

CPU Hog Debug Options (1/1)

d) Display data

Please enter selection [q=Quit]:d

Checking CPU Hog

TID Name Milliseconds

--- ---- ------------

0x8a39afe0 tSyncReq 0

0x8dfc7150 ImmGetAgent 0

0x8a412b20 AS_00001786.I 0

0x8c44fa70 apIdle 0

0x8bccd2d0 tFlowMgrPktRx 0

Even if show system-recources shows me 80% CPU Usage.

I also seen, that the CPU Spike seems to occur on both systems at the same time.

There is no traffic on the system, because it is a test enviroment. We use source-nat for outgoing traffic from our servers to DNS Servers, but there are ony a few connections.

The bug CSCec83724 is resoved, but what Version does a fix include?

So what can i do to get out the right task.

We do not use scripted keepalives, only HTTP and TCP.

Best Regards

Sven

Cisco Employee

Re: CSS 11506 - SCM CPU load

indeed the CPU hog did not provide information to decide exactly what process is the culprit.

But it is one of the 5 listed there.

Here is another procedure to capture the cpu info.

symbol-table load SPRITZ

shell 1 1 spy

wait a couple of minutes

shell 1 1 spyStop

shell 1 1 spyReport

symbol-table unload SPRITZ

Regarding the bug it will be integrated in the next 7.40 image.

Regards,

Gilles.

356
Views
0
Helpful
3
Replies