Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

CSS 115xx and 1115x Telnet issue

Hi everyone

I really hope there is a solution to this problem which has been irritating me for years:

When I copy and paste more than a few lines of config into any one of our CSSs (ver 5.00, 7.50, 8.10 all have the problem), some characters get missed, and I get syntax errors back from the device.

This applies to telnet and hyperterminal, whether serial or TCP/IP based, although the symptoms are much worse with TCP/IP.

If I specify a delay of 2000ms between lines and 30ms between characters, the config gets pasted correctly. However, this is taking a lot of time, as we make a lot of changes to the config.

I've tried a few telnet programs (Putty, etc), but they all have the same problem.

Any ideas how I can fix this?

4 REPLIES
Cisco Employee

Re: CSS 115xx and 1115x Telnet issue

this is a CSS restriction and there is no solution to make it work.

You should try to modify your config in a text file and upload the text file into the CSS via ftp.

Gilles.

New Member

Re: CSS 115xx and 1115x Telnet issue

Thanks for the reply. I see an option to copy from ftp to startup-config, but not to running-config - how does one achieve this?

Also, does copying to the config overwrite the config, or add to it (as per IOS)?

Cisco Employee

Re: CSS 115xx and 1115x Telnet issue

indeed, you can only copy to the startup-config.

What you can do is a 'archive startup-config startup-config', then copy the new config via tftp into startup-config.

Then 'copy startup-config running-config' and if necessary, you can 'restore startup-config' [the old config].

Also, the copy to startup-config is not an ADD. It's a REPLACE.

Gilles.

New Member

Re: CSS 115xx and 1115x Telnet issue

Try this telnet client. It's free. I've been able to past 100 lines at a time with it.

http://www.choung.net/misc/

275
Views
0
Helpful
4
Replies
CreatePlease to create content