Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

CSS Code upgrade.


We are upgrading a code on CSS 11503,

Current version is sg0740306s

We are upgrading to sg0810503.adi-gz

I went through the prcedure which is very clear, I am planning to upgrade it manually, my concern is on creating the ftp-record, I downloaded filezilla and started ftp, my questions are on how to proceed from here,

1) CSS management ip is so what should be my pc ip?, I assigned to my pc and I can ping the device from the CSS

2) what type of cable do I need to use?

3) I tried to open ftp in its default mode like when it starts up it will have a loop back address and 14147, when I click ok it will start and says logged on but in CSS when I create ftp-record with the ip,name and password and try to access ftp it never does

FileZilla Server version 0.9.31 beta

Copyright 2001-2009 by Tim Kosse (

Connecting to server...

Connected, waiting for authentication

Logged on

On CSS side if I try to download the software from server it says

"unable to connect to the server"

Could you please let me know where I am going wrong??

Thanks in Advance.



Re: CSS Code upgrade.

Hi Josh,

1. The IP address can be anything reachable by the CSS.

2. Don't understand this.

The loopback address and port 14147 are for administration. Check that you are actually running an FTP server by using the "netstat -a" command. Look for ports 20 and 21.

If FTP is running, do you have a firewall/ACL that is blocking inbound connections?

Check that your FTP record is pointing at the real address of the FTP server.

ftp-record DEFAULT_FTP wibble ...

and that you have valid credentials on your FTP server (logonid/password).

If that is working, try copying the running configuration to check that FTP is working as required before you kick off an upgrade:

copy running-config ftp DEFAULT_FTP wibble.txt



New Member

Re: CSS Code upgrade.

Hi Cathy,

I was able to connect, ping and even downloaded the running config, but weird thing is when I was trying to open this file it says "Access is Denied"

When I am trying to push the image to CSS it says

"CSS11503# copy ftp DEFAULT_FTP sg0810503.adi boot-image

Connecting (-)

%% General copy failure

Setting's in ftp are same when I downloaded the running-config.



Re: CSS Code upgrade.


I'd collect a packet trace from the FTP server to see what was really happening. You should be able to see the the file request and any FTP responses.

Kind Regards


Cisco Employee

Re: CSS Code upgrade.

I would try a different port than the management interface.

This interface as a lot of restrictions, it is half-duplex, ...

Try a normal port.

Just attached your pc in the network and make sure it can reach one of the normal circuit vlan. Not management.

When you do the transfer, make sure the file is in the default directory.

If you copied the config from css to ftp server, make sure the config file appears in the same directory as the css image you try to copy.


New Member

Re: CSS Code upgrade.

Thank You for your time, I dont know what was wrong, but I used freeFTPd and it worked like a charm...