Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

CSS http keepalive failes even though server responds

I recently "inherited" a CSS 11503 - I've only used ACEs before - and I want to get HTTP keepalives working.

To start, I created a test service:

lb-1# show run service sunbird-http-7025-test

!************************** SERVICE **************************

service sunbird-http-7025-test

  port 7025

  ip address 141.211.229.168

  keepalive type http

  keepalive uri "/render.userLayoutRootNode.uP"

  keepalive http-rspcode 302

  active

And verified that the server is indeed returning a 302 response:

lb-1# llama

lb-1(debug)# icp probe service sunbird-http-7025-test "/render.userLayoutRootNode.uP"

Probing 141.211.229.168:7025(-) Probing via HEAD

IP Address:       141.211.229.168

Port:             7025

URL:              /render.userLayoutRootNode.uP

HTTP Version:     1.1

Server Model:     Not Present

Server Date:      Wed, 30 Nov 2011 15:05:22 GMT

HEAD Response:    302 Moved Temporarily

Location:         http://141.211.229.168/Login

HEAD Support:     Yes

Persistence:      Yes

Keep-Alive:       Yes

Request Depth:    100

TBR:              5

Connect Time:     4 ms

Rqst/Rsp Time:    1 ms

Pipeline:         No

SSL:              No

but the service won't come up:

lb-1# show service sunbird-http-7025-test

  Name: sunbird-http-7025-test  Index: 26   

  Type: Local            State: Down

  Rule ( 141.211.229.168  ANY  7025 )

  Session Redundancy: Disabled

  Redirect Domain: 

  Redirect String:

  Keepalive: (HTTP-7025:HEAD-302:/render.userLayoutRootNode.uP   5   3   5 )

  Keepalive Error: General failure

Any/all assistance would be appreciated!

Everyone's tags (2)
2 REPLIES
Bronze

CSS http keepalive failes even though server responds

Hi Kurt,

What WebNS version are you running on that CSS? Do you have any other "class A" keepalives working (HTTP keepalives) correctly on that box for that or any other service?

This seems to be related to a known bug, the fact that ICP probe returns a correct status almost confirms my suspicion.

Tnx

__ __

Pablo

New Member

Re: CSS http keepalive failes even though server responds

This is the only http keepalive we have configured with a non-default

configuration (i.e. the only one with a keepalive uri and response code);

we have others that also use non-standard ports, and these work - e.g.:

lb-1# sho keepalive AUTO_calliope-8080

Name: AUTO_calliope-8080 Index: 7 State: Alive

Description: Auto generated for service calliope-8080

Address: 141.211.229.202 Port: 8080

Type: HTTP:HEAD:/

WebNS version? I hope you mean the SW on the box, this is the first time

I've heard of "WebNS"...

It's running 08.20.2.01

Dr. Kurt Hillig

UMNet Administration I always tell the Fax (734)763-4050

University of Michigan absolute truth, Phone (734)647-8778

Ann Arbor, MI 48105-3640 as I see it. EMail khillig(at)umich.edu

> Computers were invented to help people waste more time faster <

679
Views
0
Helpful
2
Replies