Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Duplicate IP address detected error messages.

hello,

I've setup a CSS115001 for load balancing two web servers. I am using just the basic L3 rule for load balancing and noticed that every so often I get this error:-

"MAR 17 10:00:56 1/1 29 IPV4-4: Duplicate IP address detected for vip: 65.214.xx.xx 00-03-6b-f7-3c-e1"

At first I thought maybe I had another device on the LAN that had that ip address but no. I changed the vip address in the content rule but I get the same error with the new IP address. Any ideas?

- Trevor

6 REPLIES
Bronze

Re: Duplicate IP address detected error messages.

Hi Trevor,

do you have redundancy in regards of the physical connections towards the next Layer2/3 Switches?

If yes, are both physical ports of the CSS assigned to the same vlan?

Regards,

Joerg

New Member

Re: Duplicate IP address detected error messages.

No there is no redundancy configuration.

This is what the setup looks like. We have the third port connected to the host provider's line.

!************************* INTERFACE *************************

interface e1

bridge vlan 2

description "**** Physical connection to 10.10.0.0/24 ****"

interface e2

description "**** Physical connection to 10.10.0.0/24 ****"

bridge vlan 2

interface e3

description "**** Physical connection to 65.214.57.0/24 ****"

phy 10Mbits-FD

!************************** CIRCUIT **************************

circuit VLAN1

ip address 65.214.57.xx 255.255.255.0

circuit VLAN2

ip address 10.10.0.3 255.255.255.0

!************************** SERVICE **************************

service HPServer1

ip address 10.10.0.1

active

service HPServer2

ip address 10.10.0.2

active

service Web_server1

keepalive type http

keepalive method get

keepalive uri "/"

port 80

ip address 10.10.0.1

active

service Web_server2

ip address 10.10.0.2

keepalive type http

keepalive method get

keepalive uri "/"

port 80

protocol tcp

active

!*************************** OWNER ***************************

owner L3_Owner

content L3_Rule

add service HPServer1

add service HPServer2

balance aca

vip address 65.214.57.18

active

!*************************** GROUP ***************************

group dns

add service HPServer1

add service HPServer2

vip address 65.214.57.18

active

New Member

Re: Duplicate IP address detected error messages.

Also, is this the best way to load balance 2 servers that are used for both Web and DNS?

Reason for asking is that this morning when I configured the CSS to go live, it went fine for a few minutes then crashed hard. I figured the default layer3 balancing would be fine. It went fine for testing so I'm at a loss why it crashed. It also reported this error:

"MAR 17 09:56:49 1/1 27 NETMAN-4: SNMPAPI:SNMPAPI_Set:SET failure"

New Member

Re: Duplicate IP address detected error messages.

Okay I believe I've fixed the duplicate ip message. We have a Pix Firewall connected to a port on the CSS and the global config ip range overlapped the VIP ip address used on the CSS itself.

Now this is fixed, would this have caused the CSS to crash?

Cisco Employee

Re: Duplicate IP address detected error messages.

this would not have cause a crash normally.

But it was not good anyway :-)

Gilles.

New Member

Re: Duplicate IP address detected error messages.

But what about the config that I have for layer3 load balance? That should not have caused a crash either? We have about 180-200requests a second to the web servers so I presume the CSS would not have a problem with that?

- Trevor

451
Views
0
Helpful
6
Replies