Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

FT failover not working

We have 2 ACEs configured as Active/Standby.  FT vlan is configured directly using a crossover cable , not using a switch for the FT vlan

ACE is setup in routed mode ,vlan 29 is client vlan and 28 is server vlan ,both are being trunked on ACE-- trunk  3750 switch.

When I shutdown the port on 3750 for the primary ACE , data connectivity wise ,primary ACE is down ,but the secondary is not taking over ,and also

when I do sh ft group status  on the secondary ACE,I see the status of  STANDBY_HOT and the peer state: ACTIVE.

Not sure why its not failing over . when I disable the port on switch.

below is my ft config

Primary

ft interface vlan 1003
  ip address 1.1.1.1 255.255.255.252
  peer ip address 1.1.1.2 255.255.255.252
  no shutdown

ft peer 1
  heartbeat interval 300
  heartbeat count 10
  ft-interface vlan 1003
ft group 10
  peer 1
  no preempt
  priority 255
  peer priority 250
  associate-context Admin
  inservice

ft track interface PCI
  track-interface vlan 29
  peer track-interface vlan 29
  priority 20

ft group 11
  peer 1
  no preempt
  priority 255
  peer priority 250
  associate-context EPS-PCI
  inservice

Secondary

ft interface vlan 1003
  ip address 1.1.1.2 255.255.255.252
  peer ip address 1.1.1.1 255.255.255.252
  no shutdown

ft peer 1
  heartbeat interval 300
  heartbeat count 10
  ft-interface vlan 1003
ft group 10
  peer 1
  no preempt
  priority 250
  peer priority 255
  associate-context Admin
  inservice

ft track interface PCI
  track-interface vlan 29
  peer track-interface vlan 29
  peer priority 20

ft group 11
  peer 1
  no preempt
  priority 250
  peer priority 255
  associate-context EPS-PCI
  inservice

5 REPLIES
Bronze

FT failover not working

hi

two issues which I see in your config are:

a. less priority in "ft track interface PCI"----configure a priority which will be reduced from current priority so that active will have less priority then that of standby (take 100 for e.g, so if vlan 29 go down, active priority become 255-100=155)

b. "no preempt" in FT groups----so even when priority is reduce this command will hold standby preempting the active (same like HSRP).

New Member

FT failover not working

Gaurav

Thanks for the reply ,you mean I need to change my ft track interface PCI ,priority from 20 to 100 ,and also enable the preemt command on the ft groups

On cisco docs ,its says ,when we configure FT track interface ,the ,i haven't set any peer priority so the value is 0

so (255-20 ==245)

for peer( 250-0 ==250)  stanby has high priority so it should become active.

Correct me if I am wrong

FT failover not working

Hello,

Some things here, why do not try to change the priorities of all your group to be

priority 250 / peer priority 255? There are some of them which have different priorities or even you can have the same priority and if you have preempt disabled then it will take the higher ip address configured as the prefered active.

Additionally, I wonder if you can try:

ft track interface PCI

  track-interface vlan 29

  peer track-interface vlan 1003

  priority 50

  peer priority 5

Hope this helps!!!

Jorge

New Member

Re: FT failover not working

We configured the FT

configuration of the ft interface and group on primary ace

ft interface vlan 1003
  ip address 1.1.1.1 255.255.255.252
  peer ip address 1.1.1.2 255.255.255.252
  no shutdown

ft peer 1
  heartbeat interval 300
  heartbeat count 10
  ft-interface vlan 1003
ft group 10
  peer 1
  priority 225
  peer priority 200
  associate-context Admin
  inservice

ft track interface PCI
  track-interface vlan 29
  peer track-interface vlan 29
  priority 100
  peer priority 50

ft group 11
  peer 1
  priority 225
  peer priority 200
  associate-context EPS-PROD
  inservice

when the switch port is shutdown  for the primary ACE,secondary took over for the admin context .,and the application was not reachable  as the context dint switch over ,let me know if we need to change any value

out of ft group of secondary

ace2/Admin# sh ft group status

FT Group                     : 10
Configured Status            : in-service
Maintenance mode             : MAINT_MODE_OFF
My State                     : FSM_FT_STATE_ACTIVE
Peer State                   : FSM_FT_STATE_STANDBY_HOT
Peer Id                      : 1
No. of Contexts              : 1
Running cfg sync status      : Running configuration sync has completed
Startup cfg sync status      : Startup configuration sync has completed

FT Group                     : 11
Configured Status            : in-service
Maintenance mode             : MAINT_MODE_OFF
My State                     : FSM_FT_STATE_STANDBY_HOT
Peer State                   : FSM_FT_STATE_ACTIVE
Peer Id                      : 1
No. of Contexts              : 1
Running cfg sync status      : Running configuration sync has completed
Startup cfg sync status      : Startup configuration sync has completed
ace2/Admin#

NOTE: Configuration mode has been disabled on all sessions

Bronze

Re: FT failover not working

Hi

Sorry but i didn't understand you saying "application was not reachable  as the context dint switch over", which context are we talking here "EPS-PCI", then if you use show ft track summary command it will show you which context this tracking is mapped with. in your case its only Admin to which it is mapped.

So please create a similiar track (only ft track and no other ft configuration) inside the desire context also...

624
Views
0
Helpful
5
Replies
CreatePlease login to create content