Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

HTTP url check not working

I have a simple http check, and it doesn't seem to check the URL at all.

probe http URL_Check

interval 10

passdetect interval 3

passdetect count 2

request method get url /index.shtml

expect status 200 200

open 1

expect regex "testtest1234test"

Here is the details of the probe:

sh probe URL_Check detail

probe : URL_Check

type : HTTP

state : ACTIVE

description :

----------------------------------------------

port : 80 address : 0.0.0.0 addr type : -

interval : 10 pass intvl : 3 pass count : 2

fail count: 3 recv timeout: 10

http method : GET

http url : /index.shtml

conn termination : GRACEFUL

expect offset : 0 , open timeout : 1

expect regex : testtest1234test

send data : -

------------------ probe results ------------------

associations ip-address port porttype probes failed passed health

------------ ---------------+-----+--------+--------+--------+--------+------

serverfarm : test

real : CHILD[0]

192.168.219.2 80 DEFAULT 35 0 35 SUCCESS

Socket state : CLOSED

No. Passed states : 1 No. Failed states : 0

No. Probes skipped : 0 Last status code : 0

No. Out of Sockets : 0 No. Internal error: 0

Last disconnect err : -

Last probe time : Thu Sep 24 00:56:52 2009

Last fail time : Never

Last active time : Thu Sep 24 00:51:12 2009

Any help would be great!

1 REPLY
New Member

Re: HTTP url check not working

looks like the issue is that the server isn't passing the content-length field.

128
Views
0
Helpful
1
Replies