Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

IP address appears in URL after http redirect

Do I have to have to add some DNS parameters to the CSS to avoid having the IP address of the server being exchanged for the name on the URL, after an HTTP redirect?

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: IP address appears in URL after http redirect

is the redirect sent by the CSS ?

Is it the result of configuring a redirect service or the CSS breaking persistence ?

If the later, try configuring 'persistence reset remap' in global configuration mode.

Gilles.

7 REPLIES
Cisco Employee

Re: IP address appears in URL after http redirect

is the redirect sent by the CSS ?

Is it the result of configuring a redirect service or the CSS breaking persistence ?

If the later, try configuring 'persistence reset remap' in global configuration mode.

Gilles.

New Member

Re: IP address appears in URL after http redirect

The problem occurs on HTTP>HTTPS redirects....I'm sure I've read somewhere that that some local DNS settings are required on the CSS to avoid this happening but I can't seem to find it on Cisco.

Thanks for the quick response.

New Member

Re: IP address appears in URL after http redirect

The problem occurs on HTTP>HTTPS redirects....I'm sure I've read somewhere that that some local DNS settings are required on the CSS to avoid this happening but I can't seem to find it on Cisco.

Thanks for the quick response.

Cisco Employee

Re: IP address appears in URL after http redirect

there is no local dns settings on the CSS.

Please send us your config and tell me which ip address you see.

Gilles.

New Member

Re: IP address appears in URL after http redirect

Hi Giles,

The Ip address that is returned is in the Default-Redirect service domain config below:

CSS11501# sh run

!Generated on 09/05/2006 02:08:23

!Active version: sg0810002

configure

!*************************** GLOBAL ***************************

ip redundancy master

snmp community ecoute read-only

snmp community apel read-write

app

app session 10.1.100.6

logging host 192.168.7.60 facility 5 log-level debug-7

logging buffer 10000

dns primary 10.134.174.52

host ESLNCAG01 192.168.225.40

host ESLNCAG02 192.168.225.41

ip route 0.0.0.0 0.0.0.0 192.168.225.1 1

!************************* INTERFACE *************************

interface e1

bridge vlan 225

phy 100Mbits-FD

interface e8

description "FAILOVER MD_VLAN918"

bridge vlan 918

phy 100Mbits-FD

!************************** CIRCUIT **************************

circuit VLAN225

redundancy

ip address 192.168.225.4 255.255.255.0

circuit VLAN918

ip address 10.1.100.5 255.255.255.252

redundancy-protocol

!************************** SERVICE **************************

service ESLNCAG01

ip address 192.168.225.40

active

service ESLNCAG02

ip address 192.168.225.41

active

service HTTP_REDIRECTS

ip address 2.2.2.2

keepalive type none

no prepend-http

type redirect

domain https://148.106.128.234

active

!*************************** OWNER ***************************

owner Citrix_CDS_Solution

content Citrix_CDS_443

add service ESLNCAG01

add service ESLNCAG02

vip address 192.168.225.91

protocol tcp

port 443

advanced-balance sticky-srcip

active

content DEFAULT-REDIRECT

vip address 192.168.225.91

protocol tcp

port 80

url "/*"

add service HTTP_REDIRECTS

active

Cisco Employee

Re: IP address appears in URL after http redirect

You see the ip address in the browser, because this is the redirect you configured.

domain https://148.106.128.234

Replace the ip address above with a valid domain name and this is what will appear in your client browser.

Gilles.

New Member

Re: IP address appears in URL after http redirect

You know, I feel like a burk, I had tried this before and it didn't work. Tried it now and all is fine.

Sorry to have bugged with such a trivial matter

473
Views
0
Helpful
7
Replies
CreatePlease to create content