Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

LocalDirector Load balancing of FTP

I am trying to set up FTP thru a localdirector and cannot get it to work. If I target the real address, I connect fine. If I target the virtual address, no go. I've tried SERVICE FTP-PROXY to no avail.

FTP config is:

real 165.215.41.43:21:0:tcp is

virtual 165.215.41.92:21:0:tcp is

bind 165.215.41.92:21:0:tcp 165.215.41.43:21:0:tcp

service 165.215.41.92 FTP-Proxy

I'm currently only using one real address and server until I can get localdirector to establish a connection and get a reply.

2 REPLIES

Re: LocalDirector Load balancing of FTP

Often times complex troubleshooting issues are best addressed in an interactive session with one of our trained technical assistance engineers. While other forum users may be able to help, it’s often difficult to do so for this type of issue.

To utilize the resources at our Technical Assistance Center, please visit http://www.cisco.com/tac and to open a case with one of our TAC engineers, visit http://www.cisco.com/tac/caseopen

If anyone else in the forum has some advice, please reply to this thread.

New Member

Re: LocalDirector Load balancing of FTP

Hi There

I have just read your problem and sounds like one that I had a while ago when I first started using LocalDirectors, but I hesitate to write because I did not want to sound like I was trying to teach to suck eggs.

Anyway, I was having the same trouble with a client who had a couple of webservers. They could not get a response from the virtual address but could get a response from both real address. In correct network layout, the LocalDirector, as it acts like a bridge, should be the only way that the requests can get to the servers that it is supposed to be load balancing. If it is not the only path to them, Load balancing will not occur. Hence, just check that the LocalDirector is in series with the servers and there are not any other connections to the switches that the server and LocalDirector connect to (unless you are using a resilient topology, but that still needs to be hidden behind the LDR). When we may these changes to the customers network, then everything worked perfectly.

Sorry if you have already tried this, but it is the most obvious reason for this behaviour that I can think of.

323
Views
0
Helpful
2
Replies
CreatePlease to create content