Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

MPEG-2 videos start buffering after upgrade from ACNS 4.x to 5.x

We upgraded all our CE-507's & CE-560's with ACNS 4.x to CE-510's & CE-565's with ACNS 5.x. Since then a few of our videos started to buffer before playing. Depending on the size of the video, it can now take several minutes before the clip will start playing.

In 4.x, we didn't have WMT enabled, not license keys installed, and the problem videos would play correctly. So I'm really stuck as to what is causing this.

Any help is appreciated

5 REPLIES
Silver

Re: MPEG-2 videos start buffering after upgrade from ACNS 4.x to

Standalone Content Engines can receive WMT requests directly from WMT clients, or from WCCP Version 2 routers or Layer 4 CSS switches (through WMT transparent redirection). In ACNS 5.2 software, MMS-over-HTTP is supported with Windows Media Services 9 Series.

In ACNS 5.2 software, the WMT streaming module contains two sets of processes that handle client requests:

The mms_server processes that handle MMS requests over UDP (MMSU) and TCP (MMST), and MMS-over HTTP

The mcast_mms processes that handle MMS requests over IP multicast

New Member

Re: MPEG-2 videos start buffering after upgrade from ACNS 4.x to

Thanks for the reply. I've tried both MMS and RTSP and they both act the same. I open Media Player 9, click Open URL, and the clip will open & buffer for a minute or so (depends on the file size). In Media Player, I open up the statistics window, and it's always using the HTTP protocol. I've also tried both MMSU & MMST. In both cases Media Player gives me a server error.

I've read where if it has a problem with a protocol, it will work it's way through a list of options and default to HTTP if they all fail. I've spoke with our WAN guy, and he told me there's nothing that should block the MMS port.

You mentioned the WMT streaming engine. We don't have either the Windows Media or the Real Networks pieces enabled because we don't have the licenses for them. We didn't have them turned on in 4.x, so I didn't put 100% of the focus on them. Is this another subtle change between 4.x and 5.x?

If it helps, all our equipment is up to date with ACNS 5.5.5.

Cisco Employee

Re: MPEG-2 videos start buffering after upgrade from ACNS 4.x to

ACNS 5.5 and above doesn't support MMS as Microsoft started EOS of MMS and above.

Yes, You do need to enable WMT in ACNS and Windows Media Fast start and fast cache also to avoid buffering of file before playing.

If you don't have any license enable 60 day evaluation license by wmt evauate cli.

Without WMT, ACNS can't stream your media file and it will be served from cache as http download.

New Member

Re: MPEG-2 videos start buffering after upgrade from ACNS 4.x to

The more I read, the more I was afraid of that. Good thing for me, we already have a quote from Cisco for some new equipment that included some WMT licenses. Now I just need to wait out the red tape.

Thanks again for all the help!

New Member

Re: MPEG-2 videos start buffering after upgrade from ACNS 4.x to

I should have also mentioned that we have 80 content engines deployed. Each point back to a CDM, Content Router, & Root CE that exist in our central office. Our current process is to pre-posisition all content on the local CE before it is opened to Production, and point the various offices to their local CE.

161
Views
0
Helpful
5
Replies
CreatePlease login to create content