Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

need help with layer 5 load balancing on a css11150

I appear to be having issues with an initial call to a rule that has a long delay, this causes additional request from the css to the entire server farm. I am looking for the layer 5 load balancing spec so i can see what the timeout values are. if the initial call is short, it sticks to a single server with a single session. i am using advanced balance arrowpoint cookie and have to have the sticky sessions.

4 REPLIES
New Member

Re: need help with layer 5 load balancing on a css11150

Mark,

Can you paste in your current rule, as well as any other rules with the same VIP address?

When you say it has a long delay, you mean the client pauses before sending the initial GET?

You might want to lengthen the time-out of flows for port 80 with the "flow port" command so the CSS will not time them out:

CSS(config)# flow port1 80 timeout 300

That option is not available in all version of CSS code. If it is not available, we can look at other options.

-Steve

New Member

Re: need help with layer 5 load balancing on a css11150

Thanks for the help Steve, when i refer to the long delay, i am talking about an initial http://get that passes login variables with a db lookup function that takes anywhere from 15-45 seconds to process. This seems to cause the css to perform an initial load balance by re-sending the request to all 3 servers in the farm.

content secure-81-pd26

advanced-balance arrowpoint-cookie

protocol tcp

port 81

url "/*"

vip address 10.10.8.219

add service s-01

add service s-02

add service s-03

active

New Member

Re: need help with layer 5 load balancing on a css11150

Mark,

If the request takes 15 to 45 seconds to send, you will need the "flow port" command I referenced.

Can you send in the version of software you are running? There may be other options based on that...

-Steve

New Member

Re: need help with layer 5 load balancing on a css11150

i tried the flow port command for ports 80,81, and 443. the symptoms still remain. we are using a sonicwall ssl device and the crazy thing is that it works fine if we bypass ssl. we are running version 6.10 Build 203 on the css.

109
Views
0
Helpful
4
Replies
CreatePlease login to create content