Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Oracle 11i and CSS

I am looking for some validation of my CSS11052 configs, when in use with Oracle 11i web/form servers (a pair of HPUX servers running Apache for web services and the Oracle 11i forms process).

The config's I have come up with are as follows; an suggestions/comments would be greatly appreciated.

Thank you

Rich Postmus

CCNP, CCDA

Notes:

- the uplinks are attached to a pair of 4006-L3's that are trunked/HSRP'ed together. For the CSS uplink to it's specific 4006, I have specified the actual gateway, and not the HSRP gateway.

- The script at the end is something I found on this forum; it appears to work just fine! (Thank you Darren Page).

- The web service runs on port 8000, the form service runs on port 9000.

- the pair of CSS11052's are running standard feature set, version 0503015.

#############################################################

Config for CSS - A

#############################################################

!*************************** GLOBAL *************************

app session 10.10.66.5

app

host CSS11052-A 10.10.66.6

host CSS11052-B 10.10.66.5

ip route 0.0.0.0 0.0.0.0 10.229.66.253 1

!************************* INTERFACE ***********************

interface e1

description "Crossover of CSS-A and CSS-B"

interface e2

description "4006 Uplink"

bridge vlan 2

interface e3

description "Connection to Akua"

bridge vlan 3

interface e4

description "Connection to Aesir"

bridge vlan 3

!************************** CIRCUIT ************************

circuit VLAN1

description "Crossover of CSS-A and CSS-B"

ip address 10.10.66.6 255.255.255.252

circuit VLAN2

description "Web front for Oracle11i"

ip address 10.229.66.130 255.255.255.0

ip virtual-router 1 priority 230

ip redundant-vip 1 10.229.66.129

ip critical-service 1 Router

circuit VLAN3

description "Backend for Oracle11i"

ip address 10.229.3.20 255.255.255.248

!************************** SERVICE ************************

service Aesir

ip address 10.229.3.17

keepalive type script socket-test.txt "10.229.3.17 8000 9000"

active

service Akua

ip address 10.229.3.18

keepalive type script socket-test.txt "10.229.3.18 8000 9000"

active

service Router

type redundancy-up

ip address 10.229.66.253

active

!*************************** OWNER *************************

owner L3_Owner

content L3_Rule

add service Aesir

add service Akua

vip address 10.229.66.129

param-bypass enable

advanced-balance sticky-srcip

balance aca

active

#############################################################

Config for CSS - B

#############################################################

!Active version: ap0503015

!*************************** GLOBAL *************************

app session 10.10.66.6

app

host CSS11052-A 10.10.66.6

host CSS11052-B 10.10.66.5

ip route 0.0.0.0 0.0.0.0 10.229.66.252 1

!************************* INTERFACE ************************

interface e1

description "Crossover of CSS-A and CSS-B"

interface e2

description "4006 Uplink"

bridge vlan 2

interface e3

description "Connection to Akua Secondary"

bridge vlan 3

interface e4

description "Connection to Aesir Secondary"

bridge vlan 3

!************************** CIRCUIT *************************

circuit VLAN1

description "Crossover of CSS-A and CSS-B"

ip address 10.10.66.5 255.255.255.252

circuit VLAN2

description "Web front for Oracle11i"

ip address 10.229.66.131 255.255.255.0

ip virtual-router 1 priority 200 preempt

ip redundant-vip 1 10.229.66.129

ip critical-service 1 Router

circuit VLAN3

description "Backend for Oracle11i"

ip address 10.229.3.30 255.255.255.248

!************************** SERVICE *************************

service Aesir

ip address 10.229.3.27

keepalive type script socket-test.txt "10.229.3.27 8000 9000"

active

service Akua

ip address 10.229.3.28

keepalive type script socket-test.txt "10.229.3.28 8000 9000"

active

service Router

type redundancy-up

ip address 10.229.66.252

active

!*************************** OWNER ***************************

owner L3_Owner

content L3_Rule

add service Aesir

add service Akua

vip address 10.229.66.129

param-bypass enable

advanced-balance sticky-srcip

balance aca

active

#############################################################

Script file "socket-test.txt"

#############################################################

!======================================================

! Filename: socket-test.txt

! Parameters: Host port1 port2 port3

! -> test as many ports as you want on one server with this script.

!

! This script does the following:

! Connects to a remote host on a specified tcp sockets,

! waits for X seconds and then disconnects.

!

! Failure Upon:

! Not establishing a connection with the host. If one connection

! fails, the script fails.

!

! Usage to run manually:

! script play socket-test.txt "172.17.10.10 8080 80 443"

!

!

! To run on a CSS, just add under the service as:

! service test

! keepalive type script socket-test.txt "172.17.10.10 8080 80 443"

!

!

! Written by Darren Page, Dimension Data

!

!======================================================

!

!no echo

!

! Make sure the user has a qualified number of arguments

if ${ARGS}[#] "LT" "2"

echo "Usage: socket-test.txt \'host socket1 socket2 socket3 ...'"

exit script 1

endbranch

set host "${ARGS}[1]"

! get the first tcp port ready from the ARGS array

var-shift ARGS

while ${ARGS}[#] "GT" "0"

set EXIT_MSG "Connect: Failed to connect to ${host}"

! Connect to remote host on specified port

socket connect host ${host} port ${ARGS}[1] tcp 2000

! Wait one second

pause 1

! disconnect from remote host with a TCP FIN

socket disconnect ${SOCKET} graceful

! Wait one second

pause 1

!get the next port from the array

var-shift ARGS

no set EXIT_MSG

! Demarcation of the end of the loop

endbranch

exit script 0

#############################################################

148
Views
0
Helpful
0
Replies
CreatePlease login to create content