Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Preposition 4.1 in auto-discovery mode

I am trying to configure preposition on WAE-674s with 4.1 version. I can access the related file server sharing from a standalone with the domain-name/username and password.

On the preposition windows of the central management GUI, when I push the browse button the directory (not the files in it) is shown. However preposition fails:

The attached wireshark file shows the traffic between the file server and the waas during enabling process, as I can see, I am not MS expert, after TCP handshake the WAAS don't send any packets.

accelerator cifs preposition 1008

name "Test"

server "172.27.242.222"

root "waas/"

credentials username xxx domain yyy password 1 mencrypt{zzz}

max-cache 20

min-file-size 20

no ignore-hidden-dir

recursive

scan-type full

schedule now

no enable

modified 09:10:2008 15:19:22

HOAE1674# find-pattern match "2008-10-09 16" cifs_err.log

HOAE1674#conf t

HOAE1674(config)#accelerator cifs preposition 1008

HOAE1674(config-preposition)#enable

HOAE1674(config-preposition)#

HOAE1674# find-pattern match "2008-10-09 16" cifs_err.log

2008-10-09 16:00:42,245 INFO (actona.directives.DirectivesManager:116) RMI TCP Connection(13)-127.0.0.1 - CFG:DirectiveList=[{directiveHeader={description=Test, type=preposition, lastModified=Thu Oct 09 16:00:42 EEST 2008, id=1008, created=Thu Oct 09 15:50:59 EEST 2008, status=enabled}, directiveBody={content={rootPathsList=[{FSName=172.27.242.222, DirectoryName=/, FSProtocol=CIFS, Sha

reName=waas}], ignoreHiddenDirectories=false, filePattern=[], Tx=, includeSubDir

ectories=true, rootURL=}, time={weekdays=0000000, weekday=1, days=, weekdaySerial=1, schedule=0, startTime=00:00}, preposition={prepositionType=full, user=x

xx\yyy, totalSize=20.0, minFileSize=20.0 [KB], password=mencrypt{zzz=}}}}]

2008-10-09 16:00:42,278 INFO (actona.preposition.PrepositionController:361) RMI TCP Connection(13)-127.0.0.1 - Starting preposition task - id:1008 lastRootIndex:0 server:172.27.242.222 share:waas rootPath: pattern:* recursive:true minSize:20480 maxSize9223372036854775807 full:true timeFilter:Thu Jan 01 02:00:00 EET 1

970 relative:false size:20562995200 duration:0

2008-10-09 16:00:42,279 INFO (actona.util.storage.InternalStorage:138) RMI TCP Connection(13)-127.0.0.1 - CFG: creating a new file for PREPOSITION storage: preposition_task1008.tmp

2008-10-09 16:00:42,289 INFO (actona.preposition.PrepositionController:385) RMI TCP Connection(13)-127.0.0.1 - Preposition ID 1008 started on 172.27.242.222\waas\.

2008-10-09 16:00:42,297 INFO (actona.aosh_io.AoShellWrapper:137) Thread-15 - Connect failed to [ server: 172.27.242.222, port: 445 ]

2008-10-09 16:00:42,297 INFO (actona.preposition.PrepositionController:961) Thread-15 - Connection failed to /172.27.242.222:445, falling back to port 139

2008-10-09 16:00:42,298 INFO (actona.aosh_io.AoShellWrapper:137) Thread-12 - Connect failed to [ server: 172.27.242.222, port: 139 ]

2008-10-09 16:00:42,298 WARN (actona.preposition.PrepositionController:981) Thread-12 - Preposition ID 1008 failed, reason: network initialization error, retrying in 30 seconds.

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: Preposition 4.1 in auto-discovery mode

Bulent,

The connection for the PP job needs to be optimized (i.e. needs to pass through a peer device running the CIFS AO).

Zach

6 REPLIES
Cisco Employee

Re: Preposition 4.1 in auto-discovery mode

Bulent,

Is there another WAE in between the initiating WAE and the origin file server that the PP connection can be optimized with?

Zach

Community Member

Re: Preposition 4.1 in auto-discovery mode

There is no other WAE between the initiating WAE (172.27.249.65) and the origin file server (172.27.242.222). However I can see the many connections in PT No Peer state on the WAE

HOAE1674#show stat connection all

D:DRE,L:LZ,T:TCP Optimization,

C:CIFS,E:EPM,G:GENERIC,H:HTTP,M:MAPI,N:NFS,V:VIDEO

ConnID Source IP:Port Dest IP:Port PeerID Accel

118 172.27.249.98:3727 172.27.242.222:445 0:16:9d:39:0:5b TDLG

Local IP:Port Remote IP:Port Peer ID ConnType

172.27.249.65:37407 172.27.242.222:139 N/A PT No Peer

172.27.249.65:46900 172.27.242.222:445 N/A PT No Peer

172.27.249.65:59091 172.27.242.222:445 N/A PT No Peer

172.27.249.65:38885 172.27.242.222:445 N/A PT No Peer

172.27.249.65:22833 172.27.242.222:445 N/A PT No Peer

172.27.249.65:53076 172.27.242.222:139 N/A PT No Peer

172.27.249.65:26479 172.27.242.222:139 N/A PT No Peer

172.27.249.65:14781 172.27.242.222:445 N/A PT No Peer

172.27.249.65:49619 172.27.242.222:139 N/A PT No Peer

172.27.249.65:45850 172.27.242.222:445 N/A PT No Peer

172.27.249.65:52480 172.27.242.222:139 N/A PT No Peer

172.27.249.65:14854 172.27.242.222:139 N/A PT No Peer

172.27.249.65:44079 172.27.242.222:445 N/A PT No Peer

172.27.249.65:39368 172.27.242.222:139 N/A PT No Peer

172.27.249.65:16611 172.27.242.222:445 N/A PT No Peer

172.27.249.65:45835 172.27.242.222:445 N/A PT No Peer

172.27.249.65:17755 172.27.242.222:139 N/A PT No Peer

172.27.249.65:44403 172.27.242.222:139 N/A PT No Peer

.

.

.

The WAE and file server are on different vlans of the same 6500s. The file server vlan is configured with ip wccp 62 in, however its access-list do not match the related connection.

The related config on the 6500 site:

interface Vlan311

description WAAS-Normal

ip address 172.27.249.76 255.255.255.240

ip wccp 61 group-listen

ip wccp 62 group-listen

ip pim dense-mode

standby 211 ip 172.27.249.78

standby 211 preempt

!

interface Vlan12

ip address 172.27.242.253 255.255.255.0

ip helper-address 172.27.242.121

ip wccp 61 redirect in

standby 12 ip 172.27.242.254

ip wccp 61 group-address 224.10.10.10 redirect-list 101

access-list 101 permit tcp 172.27.238.0 0.0.0.255 172.27.249.96 0.0.0.15

access-list 101 permit tcp 172.27.241.0 0.0.0.255 172.27.249.96 0.0.0.15

access-list 101 permit tcp 172.27.242.0 0.0.0.255 172.27.249.96 0.0.0.15

access-list 101 permit tcp 172.27.245.0 0.0.0.255 172.27.249.96 0.0.0.15

thanks

Bulent

Cisco Employee

Re: Preposition 4.1 in auto-discovery mode

Bulent,

The connection for the PP job needs to be optimized (i.e. needs to pass through a peer device running the CIFS AO).

Zach

Community Member

Re: Preposition 4.1 in auto-discovery mode

Hello Zach,

You are saying that the packets generated by preposition process of the waes should be optimized by the waas devices. So it means that I should not configure preposition on the core waes (waes near to file servers). Also I should remove the "redirect exclude in" lines on the interfaces facing to the branch wae devices. Do I understand correctly?

thanks,

Bulent

Cisco Employee

Re: Preposition 4.1 in auto-discovery mode

CIFS PP should be configured on the devices closest to the clients. The PP connection initiated from those devices must be optimized.

As far as removing 'redirect exclude in', I would need to take a closer look at your topology, traffic flow, and configuration. If you are performing WCCP interception on a software-based platform (ISR, 7200, etc.), then it doesn't hurt to leave it on. The WAE will try to optimize connections initiated from/destined to itself regardless of the interception method used.

Zach

Community Member

Re: Preposition 4.1 in auto-discovery mode

Thanks Zach, Seils

After preposition traffic passed through core waas devices, preposiotion worked.

240
Views
0
Helpful
6
Replies
CreatePlease to create content