Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Problem using Mozilla Firefox for service on CSS

Hi,

I have a problem with a CSS11503.

I have configured a content with a specified url for the tcp port 80.

If I use the browser Mozilla Firefox and I use the specified url (//certwww.bip.it/) all is on, but if I specify the url and the port 80 (//certwww.bip.it:80) the CSS cannot reply.

If I remove the url this problem does not exist but I cannot do it in on stream.

Can someone help me, please?!

Regards

CS

4 REPLIES
Cisco Employee

Re: Problem using Mozilla Firefox for service on CSS

:80 is the default and normally should be omitted. A browser will not send the :80.

So, I suggest you do not configure it.

If you configure it, the CSS will want to see it.

Gilles.

Community Member

Re: Problem using Mozilla Firefox for service on CSS

Hi Gilles,

sorry, but I cannot understand when you said

"So, I suggest you do not configure it." Where on the browser or on the CSS?!

I have to use on the browser because I have to do a penetration test with an application that use this one.

On CSS I have to configure it because it is mandatory, as you know.

And "If you configure it, the CSS will want to see it." where?!

Then, the CSS have to do a mapping of the port, so the client sent a request on port 80, but the real services are on dedicated port (like 2000x) specified on service section.

Thanks a lot for your suggestions!!!!

CS

Cisco Employee

Re: Problem using Mozilla Firefox for service on CSS

No, the :80 is not mandatory.

I believe it is even mandatory not to send it when using the default port.

So, the CSS should be configured without the :80 and your client should follow the HTTP spec and not send the default port with the url.

I know there was some improvement made in the code in this area, so you can try to run the very latest version and see if there is a difference.

If not, you will have the follow the recommandation I just gave you.

Gilles.

Community Member

Re: Problem using Mozilla Firefox for service on CSS

I think that :80 could be mandatory in HTTP/1.1 (not in HTTP/1.0).

So the problem (and customer the alarm!!!!) is the compliance with some future version of browser.

What do you think about?!

Thanks

CS

159
Views
0
Helpful
4
Replies
CreatePlease to create content