Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

Problem with ACE Module MAX-LOAD

Hello Everybody,

I have a problem, i've configured an ACE Module, but sometimes the state of real server is flapping betwen OPERATIONAL and

MAX-LOAD, I've seen that load value when this hapend this (MAX-LOAD) take the load value 16000 in the real server was2, but when the state is OPERATIONAL the load value of the real server is 480. anybody know how to correct this situation?

Thank You

The output i show.

ACE-MOD6/integracion1# sh serverfarm servers_unique
serverfarm     : servers_unique, type: HOST
total rservers : 3
---------------------------------
                                                ----------connections-----------
       real                  weight state        current    total      failures
   ---+---------------------+------+------------+----------+----------+---------
   rserver: was1
       10.24.18.10:0         8      OPERATIONAL  10         1110975    0
   rserver: was2
       10.24.18.11:0         8      MAX-LOAD     1          843815     3
   rserver: was3
       10.24.18.12:0         8      OUTOFSERVICE 0          177        0

ACE-MOD6/integracion1# sh serverfarm servers_unique detail
serverfarm     : servers_unique, type: HOST
total rservers : 3
active rservers: 1
description    : -
state          : ACTIVE
predictor      : LEASTLOADED
   weight            : -
   autoadjust        : MAXLOAD
failaction     : -
back-inservice    : 0
partial-threshold : 0
num times failover       : 249
num times back inservice : 252
total conn-dropcount : 0
---------------------------------
                                                ----------connections-----------
       real                  weight state        current    total      failures
   ---+---------------------+------+------------+----------+----------+---------
   rserver: was1
       10.24.18.10:0         8      OPERATIONAL  10         1110979    0
         max-conns            : 4000000   , out-of-rotation count : 0
         min-conns            : 4000000  
         conn-rate-limit      : -         , out-of-rotation count : -
         bandwidth-rate-limit : -         , out-of-rotation count : -
         retcode out-of-rotation count : -
         load value           : 480     

   rserver: was2
       10.24.18.11:0         8      MAX-LOAD     1          843815     3
         max-conns            : 4000000   , out-of-rotation count : 0
         min-conns            : 4000000  
         conn-rate-limit      : -         , out-of-rotation count : -
         bandwidth-rate-limit : -         , out-of-rotation count : -
         retcode out-of-rotation count : -
         load value           : 16000   

   rserver: was3
       10.24.18.12:0         8      OUTOFSERVICE 0          177        0
         max-conns            : 4000000   , out-of-rotation count : 0
         min-conns            : 4000000  
         conn-rate-limit      : -         , out-of-rotation count : -
         bandwidth-rate-limit : -         , out-of-rotation count : -
         retcode out-of-rotation count : -
         load value           : 80      

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

ACE-MOD6/integracion1# sh serverfarm servers_unique
serverfarm     : servers_unique, type: HOST
total rservers : 3
---------------------------------
                                                ----------connections-----------
       real                  weight state        current    total      failures
   ---+---------------------+------+------------+----------+----------+---------
   rserver: was1
       10.24.18.10:0         8      OPERATIONAL  8          1110985    0
   rserver: was2
       10.24.18.11:0         8      OPERATIONAL  3          843819     3
   rserver: was3
       10.24.18.12:0         8      OUTOFSERVICE 0          177        0

ACE-MOD6/integracion1# sh serverfarm servers_unique detail
serverfarm     : servers_unique, type: HOST
total rservers : 3
active rservers: 2
description    : -
state          : ACTIVE
predictor      : LEASTLOADED
   weight            : -
   autoadjust        : MAXLOAD
failaction     : -
back-inservice    : 0
partial-threshold : 0
num times failover       : 249
num times back inservice : 252
total conn-dropcount : 0
---------------------------------
                                                ----------connections-----------
       real                  weight state        current    total      failures
   ---+---------------------+------+------------+----------+----------+---------
   rserver: was1
       10.24.18.10:0         8      OPERATIONAL  6          1110995    0
         max-conns            : 4000000   , out-of-rotation count : 0
         min-conns            : 4000000  
         conn-rate-limit      : -         , out-of-rotation count : -
         bandwidth-rate-limit : -         , out-of-rotation count : -
         retcode out-of-rotation count : -
         load value           : 480     

   rserver: was2
       10.24.18.11:0         8      OPERATIONAL  2          843821     3
         max-conns            : 4000000   , out-of-rotation count : 0
         min-conns            : 4000000  
         conn-rate-limit      : -         , out-of-rotation count : -
         bandwidth-rate-limit : -         , out-of-rotation count : -
         retcode out-of-rotation count : -
         load value           : 480     

   rserver: was3
       10.24.18.12:0         8      OUTOFSERVICE 0          177        0
         max-conns            : 4000000   , out-of-rotation count : 0
         min-conns            : 4000000  
         conn-rate-limit      : -         , out-of-rotation count : -
         bandwidth-rate-limit : -         , out-of-rotation count : -
         retcode out-of-rotation count : -
         load value           : 80      

ACE-MOD6/integracion1# sh run
Generating configuration....


access-list anyone line 8 extended permit ip any any


probe http HTTP-get-index
  interval 4
  faildetect 2
  passdetect interval 10
  receive 2
  expect status 200 200
  open 2
probe https HTTPS-get-index
  interval 4
  faildetect 2
  passdetect interval 10
  receive 2
  ssl cipher RSA_WITH_RC4_128_MD5
  expect status 200 200
  open 2
probe snmp test-server
  interval 4
  faildetect 2
  passdetect interval 10
  receive 2
  community public
  oid .1.3.6.1.2.1.25.3.3.1.2.1
    threshold 60
    weight 8000
  oid .1.3.6.1.2.1.25.3.3.1.2.2
    threshold 60
    weight 8000


rserver host des1
  ip address 10.24.18.34
  inservice
rserver host des2
  ip address 10.24.18.35
  inservice
rserver host was1
  ip address 10.24.18.10
  inservice
rserver host was2
  ip address 10.24.18.11
  inservice
rserver host was3
  ip address 10.24.18.12

serverfarm host servers_unique
  predictor least-loaded probe test-server
  rserver was1
    probe HTTP-get-index
    probe HTTPS-get-index
    inservice
  rserver was2
    probe HTTPS-get-index
    probe HTTP-get-index
    inservice
  rserver was3
    probe HTTP-get-index
serverfarm host servers_unique_granja
  rserver des1
    inservice
  rserver des2
    inservice

class-map type management match-any ADM-CONTEX-SERV1
  2 match protocol telnet any
  3 match protocol ssh any
  4 match protocol icmp any
  5 match protocol snmp any
class-map type http loadbalance match-all Check-Headers
  2 match http url .*
  3 match http header Host header-value "10.24.16.*"
  4 match http header User-Agent header-value ".*MSIE.*"
class-map type http loadbalance match-all Check-Headers-12
  2 match http url .*
  3 match http header Host header-value "10.24.16.*"
  4 match http header User-Agent header-value ".*MSIE.*"
class-map match-all VIP-10-HTTP
  2 match virtual-address 10.24.16.10 tcp eq www
class-map match-all VIP-10-HTTPS
  2 match virtual-address 10.24.16.10 tcp eq https
class-map type http loadbalance match-all other-HTTP
  2 match http url .*
class-map type http loadbalance match-all other-http-12
  2 match http url .*
class-map match-all server-vlan-vip-12-http
  2 match virtual-address 10.24.16.12 tcp eq www
class-map match-all server-vlan-vip-12-https
  2 match virtual-address 10.24.16.12 tcp eq https

policy-map type management first-match ADM-CTX-SERV1
  class ADM-CONTEX-SERV1
    permit

policy-map type loadbalance first-match L7-logic
  class Check-Headers
    serverfarm servers_unique
  class other-HTTP
    serverfarm servers_unique
policy-map type loadbalance first-match http-12-lb
  class Check-Headers-12
    serverfarm servers_unique_granja
  class other-http-12
    serverfarm servers_unique_granja
policy-map type loadbalance first-match lb-logic
  class class-default
    serverfarm servers_unique
policy-map type loadbalance first-match lb-logic-12
  class class-default
    serverfarm servers_unique_granja

policy-map multi-match client-vips
  class VIP-10-HTTP
    loadbalance vip inservice
    loadbalance policy L7-logic
    loadbalance vip icmp-reply active
  class VIP-10-HTTPS
    loadbalance vip inservice
    loadbalance policy lb-logic
    loadbalance vip icmp-reply active
policy-map multi-match server-vip-service-policy-12
  class server-vlan-vip-12-http
    loadbalance vip inservice
    loadbalance policy http-12-lb
    loadbalance vip icmp-reply
  class server-vlan-vip-12-https
    loadbalance vip inservice
    loadbalance policy lb-logic-12
    loadbalance vip icmp-reply

interface vlan 233
  description Servidores_Balanceados_outside
  ip address 10.24.16.5 255.255.255.0
  access-group input anyone
  access-group output anyone
  service-policy input ADM-CTX-SERV1
  service-policy input client-vips
  no shutdown
interface vlan 240
  description Balanceados_Was
  ip address 10.24.18.2 255.255.255.240
  peer ip address 10.24.18.3 255.255.255.240
  access-group input anyone
  access-group output anyone
  service-policy input ADM-CTX-SERV1
  service-policy input server-vip-service-policy-12
  no shutdown

ip route 0.0.0.0 0.0.0.0 10.24.16.2

1 REPLY
Silver

Re: Problem with ACE Module MAX-LOAD

Hello,

What you are seeing is likely due to the following default behavior of the ACE:

"Whenever a server's load reaches zero, by default, the ACE uses the autoadjust feature to assign a maximum load value of 16000 to that server to prevent it from being flooded with new incoming connections. The ACE periodically adjusts this load value based on feedback from the server's SNMP probe and other configured options."

See more details at the following link.  You might want to set the autoadjust to average or just turn it off.

Using Autoadjust

http://www.cisco.com/en/US/docs/interfaces_modules/services_modules/ace/vA2_3_0/configuration/slb/guide/rsfarms.html#wp1070144

Hope this helps,

Sean

689
Views
0
Helpful
1
Replies
CreatePlease to create content