Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Problems with script keepalive - socket waitfor command

Hi All,

We have a script keepalive running for 4 different services, two services are UP and the other two are DOWN. This is the part of the script that fails:

socket connect host ${192.168.255.100} port 80 tcp 2000

socket send ${SOCKET} "GET /keepalive.asp HTTP/1.0\n"

socket send ${SOCKET} "User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)\n\n"

socket waitfor ${SOCKET} "this server is alive" 5000

socket disconnect ${SOCKET} graceful

The script is the same and the only difference was that the two that were up had a full stop (.) at the end of the 'this server is alive' string in the keepalive.asp page - however the script is not looking for a full stop (.) response ?

When the server guys added a . to the end of the 'this server is alive' string the service came alive.

Can anyone explain this behaviour ?

1 REPLY
Cisco Employee

Re: Problems with script keepalive - socket waitfor command

you are hitting the following bug:

CSCeg46589

"Scripted keepalive may fail with Script error at socket waitfor"

when the data sent by the server is exactly the same as the waitfor text, then the css would fail to match the 2.

Regards,

Gilles.

Thanks for rating this answer.

148
Views
0
Helpful
1
Replies