Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 
Community Member

Real Servers few hops away from ACE


In CSS platform is was possible to have real servers configured several hops away from CSS itself, so traffic to them from CSS would be routed over the network. In this case we of course had to use Source NAT to force the returning traffic back to CSS.

I tried to do the same thing on ACE and was surprised to see that ACE reported ARP_FAILED condition for rserver and it obviously never came up. Is this ACE limitation to have rserver reachable through Layer2, so ACE can use ARP to rservers, or is there a way around it?

Rserver config is pretty simple and I do not see any option for that....

The idea behind it is that we can use one VLAN for Virtual IPs and loadbalance between various servers located on our LAN, but not on VLANs going through ACE, so no ARP to rservers from ACE would be possible in this case. ACE would get the traffic to VIP, NAT destination and source and send the traffic to rserver over Layer 3 routed network (only 1 or 2 hops away).

BTW, is CSM having the same "limitation" as ACE (if it is really limitation) or is it like CSS?




Re: Real Servers few hops away from ACE


There is no such limitation with ACE. You can have Real servers multiple hops away with no issues.

You simply need routes defined on ACE to reach these remote real servers. ACE populates its ARP table with the ARP entry of the Gateways for such servers.

Syed Iftekhar Ahmed

Community Member

Re: Real Servers few hops away from ACE


Well...ACE itself has a default gateway through one of the VLANs trunked to it, so it knows how to get outside.

VLAN I tried to have rservers on is not trunked to ACE from Sup and I did assume that ACE will still be able to use those, but when I did "show rserver" command the status was ARP_FAILED.

ACE's ARP table does have MAC address of its default gateway and type for that entry is GATEWAY. Again, this gateway is not on the vlan rservers are on.

Not sure what to tell you, but this is what I see :-(

I am running A2(1.2) code.


Cisco Employee

Re: Real Servers few hops away from ACE


sounds like a bug.

We had one like this in previous release and it was supposed to be fixed.

You can try to remove the rserver and probe config and reconfigure.

This should make it work.


CreatePlease to create content