Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Redundant CSM probes not working using OneArmedMode+PBR

In a redundant configuration: 2xCat6500 with one CSM each, using One Armed Mode when we use Policy Based Routing for return traffic the redundant CSM probes fail. If we use Source NAT instead everything works fine (both Active and Standby ok).

The problem is that we need to user PBR because the servers need to know the source IP and we want to assure a quick failover.

3 REPLIES
Cisco Employee

Re: Redundant CSM probes not working using OneArmedMode+PBR

How did you setup PBR ??

Do you redirect the traffic to the physical ip address or the alias ?

You should point to the alias.

Gilles.

Community Member

Re: Redundant CSM probes not working using OneArmedMode+PBR

I'm pointing to the alias address. I didn't mention before but both C6500 have an IP interface configured in the Server Side VLAN and are using HSRP. I think the problem is related with that - when the redundant CSM sends the probe request, the response is routed to the active CSM. Maybe I need to define a specific PBR to the probes.

Cisco Employee

Re: Redundant CSM probes not working using OneArmedMode+PBR

I wasn't sure if you were really talking about probes or not.

You should not PBR probe responses.

Routing should work.

so, adjust your ACL/route-map and everything should be fine.

Gilles.

141
Views
5
Helpful
3
Replies
CreatePlease to create content