Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

SMTP probe failed issue on ACE

configured an SMTP application on ACE,

probe smtp PROBE_SMTP

  port 25

  interval 20

  passdetect interval 5

  passdetect count 2

  receive 1

  open 1

  expect status 211 250

getting probe failed error ,Please assist me on this ,if I need to change the probe settings.

even tried various expect status 211 211 ,and expect status 252 254 ,but still getting the probe failed error

production# sh serverfarm SMTP1

serverfarm     : SMTP1, type: HOST
total rservers : 2
state          : INACTIVE
DWS state      : DISABLED
---------------------------------
                                                ----------connections-----------
       real                  weight state        current    total      failures
   ---+---------------------+------+------------+----------+----------+---------
   rserver: smtp01p
      x.x.x.x:0       8   PROBE-FAILED    0          0          0
   rserver: smtp02p
       x.x.x.x:0      8   PROBE-FAILED    0          0          0

2 ACCEPTED SOLUTIONS

Accepted Solutions
Community Member

SMTP probe failed issue on ACE

If your rservers are up, the VIP will forward your packets as your configured your ACE. If the rservers are down, nothing will be forwarded. But depending on your rservers, you can trigger the way how the VIP is responding to ICMP.

Community Member

SMTP probe failed issue on ACE

Hello!

As long as you dont fix the 554-status, your vip will not come up. Does the servers respont normally to SMTP if you reach them directly (not over ACE)?

10 REPLIES
Community Member

SMTP probe failed issue on ACE

What is "show probe xxxx detail" saying?

Community Member

SMTP probe failed issue on ACE

production# sh probe PROBE_SMTP1 detail

probe       : PROBE_SMTP1
type        : SMTP
state       : ACTIVE
description :
----------------------------------------------
   port      : 25           address   : 0.0.0.0
   addr type : -            interval  : 20      pass intvl  : 5   
   pass count: 2            fail count: 3       recv timeout: 1   
   conn termination : GRACEFUL 
   expect offset    : 0         , open timeout     : 1        
   expect regex     : -
   send data        : -
                ------------------ probe results ------------------
   associations     ip-address         port porttype probes failed passed health
   ------------ ----------------------+----+--------+------+------+------+------
   serverfarm  : SMTP1
     real      : smtp01p[0]
                        x.x.x.x   25 PROBE   8552   8552   0      FAILED

   Socket state        : CLOSED
   No. Passed states   : 0         No. Failed states : 1
   No. Probes skipped  : 0         Last status code  : 554
   No. Out of Sockets  : 0         No. Internal error: 0
   Last disconnect err : Received invalid status code
   Last probe time     : Sat Jun  4 01:18:42 2011
   Last fail time      : Fri Jun  3 13:25:45 2011
   Last active time    : Never

     real      : smtp02p[0]
                        x.x.x.x   25 PROBE   8549   8549   0      FAILED

   Socket state        : CLOSED
   No. Passed states   : 0         No. Failed states : 1
   No. Probes skipped  : 0         Last status code  : 554
   No. Out of Sockets  : 0         No. Internal error: 0
   Last disconnect err : Received invalid status code
   Last probe time     : Sat Jun  4 01:18:43 2011
   Last fail time      : Fri Jun  3 13:26:01 2011
   Last active time    : Never

Community Member

SMTP probe failed issue on ACE

I guess you can nearly answer the question by yourself now ;-)

serverfarm  : SMTP1

     real      : smtp01p[0]

                        x.x.x.x   25 PROBE   8552   8552   0      FAILED

   Socket state        : CLOSED
   No. Passed states   : 0         No. Failed states : 1
   No. Probes skipped  : 0         Last status code  : 554
   No. Out of Sockets  : 0         No. Internal error: 0
   Last disconnect err : Received invalid status code
   Last probe time     : Sat Jun  4 01:18:42 2011
   Last fail time      : Fri Jun  3 13:25:45 2011
   Last active time    : Never

     real      : smtp02p[0]
                        x.x.x.x   25 PROBE   8549   8549   0      FAILED

   Socket state        : CLOSED
   No. Passed states   : 0         No. Failed states : 1
   No. Probes skipped  : 0        Last status code  : 554
   No. Out of Sockets  : 0         No. Internal error: 0
   Last disconnect err : Received invalid status code
   Last probe time     : Sat Jun  4 01:18:43 2011
   Last fail time      : Fri Jun  3 13:26:01 2011
   Last active time    : Never

The explaination you will find here:

http://www.google.de/url?sa=t&rct=j&q=smtp+status+code&source=web&cd=6&ved=0CE0QFjAF&url=http%3A%2F%2Fwww.answersthatwork.com%2FDownload_Area%2FATW_Library%2FNetworking%2FNetwork__3-SMTP_Server_Status_Codes_and_SMTP_Error_Codes.pdf&ei=5sPoTraLOMfMswb...

Community Member

SMTP probe failed issue on ACE

Marko thanks for your reply

554 -status code ,it looks like coming from the server ,they need to change the settings at there end .

But even if the probes are failing ,vip always need to be in the active state.or does it become active when the probes are successfull.

Please help in understanding this

Community Member

SMTP probe failed issue on ACE

If your rservers are up, the VIP will forward your packets as your configured your ACE. If the rservers are down, nothing will be forwarded. But depending on your rservers, you can trigger the way how the VIP is responding to ICMP.

Community Member

SMTP probe failed issue on ACE

Marko

This is how I set up my SMTp application ,instead of  using SMTP1 probe when i configure ICMP probe ,servers are operational ,but still I am unable to ping the VIP.

Tried pinging the vip from  different servers in the same subnet and vlan ,no response .

Let me know if I am missing any config in this

probe smtp PROBE_SMTP1
  port 25
  interval 20
  passdetect interval 5
  passdetect count 2
  receive 1
  open 1
  expect status 211 250

serverfarm host SMTP
  predictor leastconns
  probe PROBE_SMTP1
  rserver smtp01
    inservice
  rserver smtp02
    inservice
class-map match-all SMTP1_CLASS
  2 match virtual-address 10.12.133.27 tcp eq smtp

sticky ip-netmask 255.255.255.255 address source SMTP1_STICKY
  replicate sticky
  serverfarm SMTP1
policy-map type loadbalance first-match SMTP1_POLICY
  class class-default
    sticky-serverfarm SMTP1_STICKY

policy map multimatch PoLICY
class SMTP1_CLASS
    loadbalance vip inservice
    loadbalance policy SMTP1_POLICY
    loadbalance vip icmp-reply active

Community Member

SMTP probe failed issue on ACE

Where did you applied your service-policy? Global or local on the interface?

Community Member

Re: SMTP probe failed issue on ACE

Its applied globally .

Community Member

Re: SMTP probe failed issue on ACE

Marko

Please help me on this,as tried various options still no using getting the SMTP status code as 554.

Tried pinging the vip from  different servers in same subnet ,vip is not pingable.not sure if I am missing any of the config

servers are pingable ,but not the vip

Community Member

SMTP probe failed issue on ACE

Hello!

As long as you dont fix the 554-status, your vip will not come up. Does the servers respont normally to SMTP if you reach them directly (not over ACE)?

1260
Views
0
Helpful
10
Replies
CreatePlease to create content