Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Standby CM Hangs in pending state

I have a Standby CM running 4.0.9 that we just installed. Tried to upgrade it to 4.0.19 and it just sat there in pending state for a long time. It appeared to be hung because I couldn't get to it remotely any longer. Rebooted the box and set it up as an AA instead. The game plan was to get it upgraded, then convert it to a Standby CM. So now the box sit's, showing online via the CM as a Standby CM (even though it's set to AA) and it still sits there in pending state. How can I get this resolved? TIA

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: Standby CM Hangs in pending state

You cannot change device mode from the CM, only from the command line. I would de-register it from the CM again, configure the device mode, set the role as standby and then re-register it. Otherwise it's database settings may not allow it to function correctly. Changing device modes is a fairly intrusive process in CMS.

Interesting interface note. I have not seen that to date, however if you can recreate it, I would have the TAC open a DDTS on it. It would be worth tracking.

Dan

4 REPLIES
Cisco Employee

Re: Standby CM Hangs in pending state

What version is the Primary CM running? standby CMs are only online if the primary and standbys are running the same version.

If you are converting it to a AA, I would restore factory default, delete it from the CM and readd it so it's database entries as a CM are removed.

Hope that helps,

Dan

Community Member

Re: Standby CM Hangs in pending state

The Primary CM is running 4.0.19. I managed to blow it away in the Primary CM. Forced a CMS de-registration on the AA. Re-registered it as an AA and got the code upgraded to 4.0.19. (I did hit what I believe is a bug her which I will explain later). Now I need to change it's funtion to a Standby CM but I don't know if I can do this from the Primary CM.

So the bug I hit was that when the WAAS was rebooted to load the new code I lost connectivity for a long time. Check the switch that it was connected to and saw the interface was up/down. Bounced the interface on the WAAS and it came back. Fortunate for me the box is in our DC. Had this been remote I'm not sure a bounce of the switch interface would have worked. FYI - I have my interfaces on an etherchannel with the load-balancing set to ip-dst (round-robin didn't work).

Cisco Employee

Re: Standby CM Hangs in pending state

You cannot change device mode from the CM, only from the command line. I would de-register it from the CM again, configure the device mode, set the role as standby and then re-register it. Otherwise it's database settings may not allow it to function correctly. Changing device modes is a fairly intrusive process in CMS.

Interesting interface note. I have not seen that to date, however if you can recreate it, I would have the TAC open a DDTS on it. It would be worth tracking.

Dan

Community Member

Re: Standby CM Hangs in pending state

Ok, so I followed your advice and it appears to have worked. Thank you.

On the etherchanneling issue I had I found flow-control desireable set on 'some' of the interfaces. Shut if off and it appears to be stable.

146
Views
10
Helpful
4
Replies
CreatePlease to create content