Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Stickness configuration

Hi all,

I configured ACE like below configuration .so users connecting to server as http://10.244.0.50:7778 its oracle forms server.While users connecting through SLb they are getting disconnection in 1 min.How to create http cookie for this url.I tried to find out cookie in browse its not showing any cookie.

resource-class HTTP

limit-resource all minimum 10.00 maximum unlimited

boot system image:c4710ace-mz.A3_2_0.bin

hostname OICL_1

interface gigabitEthernet 1/1

switchport access vlan 100

no shutdown

interface gigabitEthernet 1/2

switchport access vlan 60

no shutdown

interface gigabitEthernet 1/3

shutdown

interface gigabitEthernet 1/4

shutdown

context Admin

member HTTP

[7m--More--[m

access-list ALL line 8 extended permit ip any any

access-list Realservertoslb line 1 extended permit ip any any

probe icmp ICMP

interval 15

passdetect interval 60

rserver host realserver1

description application

ip address 10.244.0.31

conn-limit max 4000000 min 2000000

probe ICMP

weight 20

inservice

rserver host realserver2

ip address 10.244.0.71

conn-limit max 4000000 min 2000000

probe ICMP

weight 20

inservice

[7m--More--[m

rserver host realserver3

ip address 10.244.0.74

conn-limit max 4000000 min 2000000

probe ICMP

weight 25

inservice

rserver host realserver4

ip address 10.244.0.77

conn-limit max 4000000 min 2000000

probe ICMP

weight 30

serverfarm host HTTP_farm

retcode 200 500 check count

rserver realserver1 7778

conn-limit max 4000000 min 4000000

inservice

rserver realserver2 7778

conn-limit max 4000000 min 4000000

inservice

rserver realserver3 7778

[7m--More--[m

conn-limit max 4000000 min 4000000

inservice

rserver realserver4 7778

conn-limit max 4000000 min 4000000

sticky ip-netmask 255.0.0.0 address both group1

serverfarm HTTP_farm

1 static client source 10.244.0.153 destination 0.0.0.0 rserver realserver1 77

78

class-map match-all HTTP_SERVICE

2 match virtual-address 10.244.0.50 tcp eq 7778

class-map match-all NAT_CLASs

2 match access-list Realservertoslb

class-map type http loadbalance match-any default-compression-exclusion-mime-typ

e

description DM generated classmap for default LB compression exclusion mime ty

pes.

2 match http url .*gif

3 match http url .*css

4 match http url .*js

5 match http url .*class

[7m--More--[m

6 match http url .*jar

7 match http url .*cab

8 match http url .*txt

9 match http url .*ps

10 match http url .*vbs

11 match http url .*xsl

12 match http url .*xml

13 match http url .*pdf

14 match http url .*swf

15 match http url .*jpg

16 match http url .*jpeg

17 match http url .*jpe

18 match http url .*png

class-map type management match-any remote_access

201 match protocol xml-https any

202 match protocol icmp any

203 match protocol telnet any

204 match protocol ssh any

205 match protocol http any

206 match protocol https any

207 match protocol snmp any

[7m--More--[m

policy-map type management first-match remote_mgmt_allow_policy

class remote_access

permit

policy-map type loadbalance first-match HTTP_SERVICE-l7slb

class default-compression-exclusion-mime-type

serverfarm HTTP_farm

class class-default

serverfarm HTTP_farm

compress default-method gzip

policy-map type inspect http all-match HTTP_SERVICE-http

class class-default

permit

policy-map multi-match NATpolicy

class NAT_CLASs

nat dynamic 101 vlan 100

policy-map multi-match int100

class HTTP_SERVICE

loadbalance vip inservice

loadbalance policy HTTP_SERVICE-l7slb

[7m--More--[m

loadbalance vip icmp-reply active

nat dynamic 101 vlan 100

inspect http policy HTTP_SERVICE-http url-logging

1 REPLY
Cisco Employee

Re: Stickness configuration

ace can create its own cookie

sticky cookie MyCookie ...

cookie insert

serverfarm ....

Then use the sticky-serverfarm above instead of your existing serverfarm.

Gilles.

384
Views
0
Helpful
1
Replies