Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Strange Issue with ACE Cookie Stickiness - HTTP 503 Service Unavailable

Hello,


I have configured cookie based stickiness on a serverfarm with two nodes. I have noticed that only 'few' pages on our web site experiences a hang (blank white page/HTTP 503 - Service Unavailable) due to enabling the cookies. The stickiness continues to work properly though.

However, if I were to disable cookies and enable source IP based stickiness, the whole web site runs perfectly without any issues.

I have also checked the release notes to see if similar bugs have been reported. Please advise what could be the reason for this strange issue and how could it be fixed.

ACE Module Version: A2(2.0) Buld 3.0(0)A2(2.0)

Thanks.

4 REPLIES
Bronze

Re: Strange Issue with ACE Cookie Stickiness - HTTP 503 Service

Have you taken a look at the webserver log? Any chance the presence of the ACE-generated cookie presents a problem at the webserver?

I would probably run a trace to see what actually happens when this error occurs. Also, try'n take a look at the http-stats on the ACE, 'show stat http', and see if ACE reports an unexpected level of errors. I've experienced issues with abnormal session termination, simply because the http-header exceeded the default header-length, that ACE permits.

New Member

Re: Strange Issue with ACE Cookie Stickiness - HTTP 503 Service

Stumbled across the same problem.  Anyone found a solution?

Cisco Employee

Re: Strange Issue with ACE Cookie Stickiness - HTTP 503 Service

Hi,

As UHansen1976 mentioned this kind of issues are most of the times related to parse-length buffer size being exceeded.

Please paste the output of the following commands:

ACE-K/Admin# sh np 1 me-stats "-shttp -v" | include parse

ACE-K/Admin# show stats http

Did you run into the same problem when the sticky method was changed to Sticky-SrcIP?

Thanks

__ __

Pablo

New Member

Re: Strange Issue with ACE Cookie Stickiness - HTTP 503 Service

Found some max parslen errors and set it to 16384. Counters do not increase now, but i still have the problem with the sharepoint IIS7 in the background.

Getting

Service Unavailable


HTTP Error 503. The service is unavailable.

from the ACE. Have switched from http cookie stickyness to ip stickyness, with no success. Seems like it has even get worse.

Don't know where the problem resides. Maybe with integrated windows authentication ntlm needed?

Frank

853
Views
0
Helpful
4
Replies