Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Trying to configure C2621 with WCCP/NAT/CEF/CBAC

Has anyone tried configuring a Cisco 2621 with NAT/CBAC/CEF/WCCP simultaneously? I have a branch office connection with a single router and am having serious trouble getting CBAC and WCCP to work nicely together. I'm redirecting to a Volera Cache Engine. If I configure the router with CBAC but no WCCP, web browsing is fine. I can also run WCCP without CBAC fine. I cannot get the router to run both simultaneously. When I do have CBAC enabled, I'm able to point my browsers to the manual proxy setting of the cache engine over port 8080 and web surfing works fine. There is something going on with the WCCP portion of this configuration. Thanks for any light anyone can shed on this. (Web cache server is on internal network 10.32.2.13).

Synopsis of config:

ip wccp web-cache redirect-list http

ip wccp 98 redirect-list streams

ip cef

ip inspect audit-trail

ip inspect name filter cuseeme

ip inspect name filter ftp

ip inspect name filter h323

ip inspect name filter http java-list 90

ip inspect name filter netshow

ip inspect name filter realaudio

ip inspect name filter rtsp

ip inspect name filter streamworks

ip inspect name filter tcp

ip inspect name filter udp

ip inspect name filter vdolive

ip audit notify log

interface FastEthernet0/0

ip address 10.32.2.1 255.255.255.0

ip nat inside

ip wccp web-cache redirect in

ip wccp 98 redirect in

interface Serial0/0.100 point-to-point

ip address 100.100.100.217 255.255.255.252

ip access-group 101 in

ip nat outside

ip inspect filter out

interface FastEthernet0/1

ip address 32.100.100.241 255.255.255.248

ip nat pool office-net 32.100.100.245 32.104.73.246 netmask 255.255.255.248

ip nat inside source list 99 pool office-net overload

ip access-list extended http

permit tcp any any eq www

ip access-list extended streams

permit tcp any any eq 1755

permit udp any any eq 1755

permit udp any any eq 554

permit tcp any any eq 554

access-list 90 permit any

access-list 99 permit any

access-list 101 permit (all my vpn tunnel entries)

access-list 101 permit (certain icmp)

access-list 101 deny ip any any log

1 REPLY
Silver

Re: Trying to configure C2621 with WCCP/NAT/CEF/CBAC

You might check for bugs on your IOS. It sounds like a bug to me. Or perhaps the router is just overworked with all those features turned on. Have you looked at resources available (memory, processor, etc.)?

266
Views
0
Helpful
1
Replies