Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Upgrading code on CSS scripts error - Script failed to load.

Hello all i tried upgrading the code on the CSS from version 7.20.0.03 to version 7.40.2.02. Before the upgrade I archived the scripts file called ap-kal-tcp-ports that I use for the keepalives.

After the software upgrade I restored the script file but every service instance that uses that script shows up the error - "Script Error: Script failed to load. Is script present on disk?"

I see the script on the disk, and I can use the script manually by running "script play".

I had to boot using the old code and the keepalives that use the scripts started working.

Anyone see this problem before?

Thank you

Dmitry.

2 REPLIES
Cisco Employee

Re: Upgrading code on CSS scripts error - Script failed to load.

Dmitry,

not sure why you want to go to 7.40.

We don't provide software fix for this version anymore.

You should try 8.20 latest.

Is the script you mentioned the only having the issue ?

Try to copy it to a ftp server and re-import it.

Also try another reboot after the upgrade if the script still fails.

Or you can try to remove all the probes using that script and then reconfigure them.

This should force the CSS to reload the script.

Gilles.

New Member

Re: Upgrading code on CSS scripts error - Script failed to load.

Hi Gilles. Thanks you for the suggestions. I am upgrading to 7.4 as an intermediate step to upgrading to 8.10.5.0, as recommended by Cisco TAC engineer.

Can we go directly to 8.20?

Dmitry.

207
Views
0
Helpful
2
Replies