Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

VIP CONFIGURATION

I have an ACE with three interfaces

Interface 1 is Outside  ( 172.16.10.1 )
Interface 2 in Inside   ( 10.20.0.1 )
Interface 3 is DMZ      ( 10.30.0.1 )

The VIPS on the ACE are in the range 172.16.10.50 to 172.16.10.100
I have one VIP defined on the ACE 172.16.10.70 listening on port 135 and has two servers under it 10.30.0.10 and 10.30.0.11

A server in the DMZ range (10.30.0.25) is trying to hit the VIP 172.16.10.70 and not getting any response
Any thoughts on what I have done wrong?

Here is my config
-------------------------

rserver host Server1
ip address 10.30.0.10
inservice

rserver host Server1
ip address 10.30.0.11
inservice

serverfarm host vip-172.16.10.70
  rserver Server1
    inservice
  rserver Server2
    inservice

class-map match-any vip-172.16.10.70
match virtual-address 172.16.10.70 tcp eq 135


policy-map type loadbalance first-match vip-172.16.10.70
  class class-default
    serverfarm vip-172.16.10.70


policy-map multi-match DMZ
class vip-vip-172.16.10.70
   loadbalance vip inservice
   loadbalance policy vip-vip-172.16.10.70
   loadbalance vip icmp-reply
   loadbalance vip advertise active
policy-map multi-match inbound
class vip-vip-172.16.10.71
   loadbalance vip inservice
   loadbalance policy vip-vip-172.16.10.71
   loadbalance vip icmp-reply
   loadbalance vip advertise active
class vip-vip-172.16.10.72
   loadbalance vip inservice
   loadbalance policy vip-vip-172.16.10.72
   loadbalance vip icmp-reply
   loadbalance vip advertise active


interface vlan 100
  description outside
  service-policy input inbound

interface vlan 200
  description Inside
  service-policy input inbound

interface vlan 300
  description dmz
  service-policy input DMZ
  nat-pool 1 10.30.0.50 10.30.0.50 netmask 255.255.255.255  ==>> I have this line defined. Not sure whats its doing.

1 REPLY

Re: VIP CONFIGURATION

you need to add the following commands

class vip-vip-172.16.10.70
nat dynamic 1 vlan 300------------Add
interface vlan 300
nat-pool 1 10.30.0.50 10.30.0.50 netmask 255.255.255.255 pat---------Add

989
Views
0
Helpful
1
Replies
CreatePlease to create content