Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

WAAS 4.0.17 self-diag and warnings

After upgrading to 4.0.17, I noticed that there is now a 'test self-diagnostics all' command. After running this on my 612 Edge WAE, I received the following warnings:

Test WARN [tfo]

WARN ASYMMETRIC Asymmetric routing is seen in the device

Action:

Check router's network configuration and WCCP redirection on the router.

and

Test WARN [wafs]

WARN NO_WAFS_CONN No transport connection to configured CIFS WAE peer

10.104.192.3

Action:

CIFS transport tunnel is not established to the device. Please check if WAF

S services are running correctly on that device and/or connectivity is configure

d properly for this device.

We are having a few issues with the initial rollout WAAS and this self-diag confirms some things, but can anyone give me some troubleshooting steps to resolve these warnings?

At the edge, we're running a 3750 and 612 WAE. At the core we're running a 512 CM and 612 core WAEs.

Here's a portion of the 3750 config that contains the WCCP info:

**to WAN**

!

interface Vlan1

description Backbone Subnet

ip address 10.96.192.14 255.255.255.240

ip wccp 62 redirect in

!

**to clients**

!

interface Vlan200

ip address 10.100.8.7 255.255.248.0

ip wccp 61 redirect in

!

**to WAE **

!

interface GigabitEthernet1/0/7

switchport access vlan 500

!

!

interface Vlan500

description Management Subnet

ip address 10.96.208.254 255.255.255.128

!

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: WAAS 4.0.17 self-diag and warnings

David,

Yes, this is normal. Only the WAFS Core service is listening on tcp/4050.

Can you verify by connecting to the individual device GUIs that the WAFS services are started?

Zach

6 REPLIES
Bronze

Re: WAAS 4.0.17 self-diag and warnings

The issue is seen on the Edge devices, and wrongly prompts on missing transport connection to the Core device.

'test self-diagnostic all' fails to validate wccp settings. . Try this bug CSCsl42759

http://www.cisco.com/en/US/prod/collateral/contnetw/ps5680/ps6870/data_sheet_cisco_wide_area_application_services_WAAS_software_version_4_0.html

http://www.cisco.com/en/US/prod/collateral/contnetw/ps5680/ps6870/prod_white_paper0900aecd806d976a.html

Cisco Employee

Re: WAAS 4.0.17 self-diag and warnings

David,

There are two warnings in the diagnostic output:

The [tfo] warning is raised when the 'Asymmetric Client' or 'Asymmetric Server' counters in the 'sh stat tfo pass-through' command output are greater than zero. This is an indication that interception is not happening bi-directionally. You should verify that there are no network paths between the client and server with WCCP configured.

The [wafs] warning means that the WAFS Edge service is not able to connect to the WAFS Core service running on 10.104.192.3. You should verify that all of the WAFS services are started, and that there is nothing blocking communication between the devices on TCP port 4050 (the cisco-wafs port).

Regards,

Zach

New Member

Re: WAAS 4.0.17 self-diag and warnings

Good info. Thanks.

Regarding port 4050 for WAFS. Should I be able to telnet to each peer (edge-to-core and core-to-edge) on this port? If there is an issue on the WAE, how would I go about restarting or starting the dependant service?

I think the tfo warnings were leftover stats when we were configuring. Cleared up now.

Thanks,

David

New Member

Re: WAAS 4.0.17 self-diag and warnings

Regarding WAFS communication, I can get to port 4050 from edge-to-core, but not from core-to-edge. Is this normal?

Cisco Employee

Re: WAAS 4.0.17 self-diag and warnings

David,

Yes, this is normal. Only the WAFS Core service is listening on tcp/4050.

Can you verify by connecting to the individual device GUIs that the WAFS services are started?

Zach

New Member

Re: WAAS 4.0.17 self-diag and warnings

I have verified that all is working through the WAE GUIs and the core service is listening on tcp/4050 now.

Thanks for your help, Zach!

David

467
Views
5
Helpful
6
Replies
CreatePlease to create content