Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Attention: The Community will be in read-only mode on 12/14/2017 from 12:00 am pacific to 11:30 am.

During this time you will only be able to see content. Other interactions such as posting, replying to questions, or marking content as helpful will be disabled for few hours.

We apologize for the inconvenience while we perform important updates to the Community.

New Member

WAAS Critical Issue - Producing Outages

Hi All,

We have a setup to which we are going to implement WAAS. Datacenter having One Central Manager(512) + WAE (512) and Branch location having WAE (512).

Both the Core WAE and Branch WAE are registered to CM and shows online. But Branch WAE is flapping between online and offline states.

The Following Shows the IOS versions

CM WAAS version 4.0.19

WAE (Inline Card) : WAAS version 4.1.1c

Branch WAE : WAAS version 4.0.17

We thought of swapping the boxes of Core WAE and Branch WAE and the Problem still persist. After further troubleshooting we found that their is a mismatch in IOS Version.

Please suggest whether this offline state occurs because of this IOS version or not ?

Branch WAE : WAAS version 4.0.17

9 REPLIES
Cisco Employee

Re: WAAS Critical Issue - Producing Outages

The reason your edge is flapping is that the CM is a newer version then your edge and both are running 4.0. Manually upgrade your edge to 4.0.19 and it will stop. Or you can upgrade your CM to 4.1.x and that will help as well. I would definitely attempt to minimize your version mismatches and try to make them all the same version if at all possible.

As a reminder, in the 4.0 code, the CM has to be the oldest version. Once you start moving to 4.1, the CM needs to be the newest code version. With CM running 4.1, you can run mixed versions of 4.0 and 4.1.

Thanks,

Dan

New Member

Re: WAAS Critical Issue - Producing Outages

Hi Dan,

Thanks for your reply. May i know whether this mismatch of IOS causing the WAAS to un optimize the traffic?

Test Lab

FTP service is configured at one PC at datacenter and client branch is trying to access the Files through FTP.

Observations

------------

1. Without WAAS in network the download time takes around 5 Sec for 18MB file ( Client at Branch accessing FTP server at DC ).

2. Core WAAS as inline mode in DC and Edge WAAS as in WCCP mode. Downloading the same file takes around 110 Sec.

3. Core WAAS and Edge WAAS are both in WCCP mode. Download takes 11 Sec.

Please suggest do we have to configure the file services for that specific FTP server or allowing WAAS to detect the servers automatically.

We have done all the basic configuration and registered the WAE devices with CM. And Applied Default policy settings in both WAE's even, After download it is observed that all the traffic showing in "Pass through" instead of optimized mode.

In addition while checking in Connection statistics we were able to view the source and destination device IP's, but the other fields like peer id, optimization, start time, end time durations showing blank.

Please suggest or provide any POC document with test results, this would be helpful in sorting out the issue.

Thanks in advance.

Regards,

Arun

Cisco Employee

Re: WAAS Critical Issue - Producing Outages

Arun,

The WAAS software mismatch should not have effected optimization, only the status of the WAE in the CM GUI (which is monitored by the CMS process). It would have impacted configuration pushes and statistics gathering to and from the CM.

From your lab description, it looks like you have several possible issues.

1. The fact you are getting all PT means you may be missing interception somewhere. What reason/discription do the PT connections give you? Are they the same on both sides? WCCP may have some configuration issues (services are not applied in the correct directions on the router interfaces, your redirect-list isn't allowing the traffic to be processed by WCCP, etc.). I often have customers step through the "Quick configuration guide" on cisco.com to double check setup.

http://www.cisco.com/en/US/docs/app_ntwk_services/waas/waas/v411/quick/guide/waasqcg.html

The guide covers both WCCP and inline. Common issues with inline can be duplex mismatches and ensuring that the network cables are utilizing the same inline group. WCCP could be several different issues, starting with redirection loops and/or mis

2. Is it all ethernet connected (no actual WAN links or latency)? You are getting a pretty fast initial download of your FTP file. If your network is all directly connected, I'm not sure you will actually see much improved speeds. Remember, there is some overhead to WAAS as it performs optimization to traffic.

3. ALWAYS go back and check your speed/duplex settings on your interfaces. I have seen (especially in test labs) where a client/server or a network device interface is autonegotiated to 10/half and it really can throw your speed tests.

If all else fails, post your topology and configs and we can take a look at them.

Good luck!

Dan

New Member

Re: WAAS Critical Issue - Producing Outages

Hi DAN,

Thanks for the Response , we are anticipatingly trying to sort out the issue.

Please inform whether the Device going to offline with CM, will optimize the traffic or not. If so do we require to downgrade one of the WAE having 4.1 to 4.0 version???

Here with am attaching the Configuration of all the devices in the Test Lab.

IP Segments assigned and Locations

----------------------------------

DC Server IP - 172.16.40.202/28

DC CM IP - 172.16.40.206/28

DC WAE IP - 172.16.39.205/28

Branch WAE - 10.10.10.5/24

Branch Client Machine - 20.20.20.5/24

DC Router - 3845

Branch Router - 1841

WAN connectivity is in Ethernet and is of 192.168.1.0/30 Segment.

Please correct us after checking the configuration if something seems mismatching.

Please find the configuration of the Network Devices.

DC Router

---------

ip wccp 61 redirect-list 110

ip wccp 62 redirect-list 110

ip cef

!

!

!

interface GigabitEthernet0/0.10

description *** DC WAE ***

encapsulation dot1Q 10

ip address 172.16.39.195 255.255.255.240

ip wccp redirect exclude in

!

interface GigabitEthernet0/0.20

description *** Client PC Segment ****

encapsulation dot1Q 20

ip address 172.16.40.195 255.255.255.240

ip wccp 61 redirect in

ip wccp 62 redirect out

!

interface GigabitEthernet0/1

description *** WAN Router ***

ip address 192.168.1.1 255.255.255.252

duplex auto

speed auto

media-type rj45

no keepalive

!

ip route 10.10.10.0 255.255.255.0 192.168.1.2

ip route 20.20.20.0 255.255.255.0 192.168.1.2

ip route 172.28.21.0 255.255.255.0 192.168.1.2

ip route 172.28.22.0 255.255.255.0 192.168.1.2

!

!

!

end

-----------------------------------------

DC Switch

---------

ter

DC-Switch#terminal le

!

vlan 10,20

!

!

interface GigabitEthernet1/0/1

description ***Connecting WAE LO ***

switchport access vlan 10

switchport mode access

!

interface GigabitEthernet1/0/2

description *** CM Connecting ****

switchport access vlan 20

switchport mode access

!

interface GigabitEthernet1/0/5

switchport access vlan 20

switchport mode access

interface GigabitEthernet1/0/13

description *** 3845 Router connecting ***

switchport trunk encapsulation dot1q

switchport mode trunk

-----------------------------------------

Branch Router

-------------

ip wccp version 2

ip wccp 61

ip wccp 62

ip cef

!

!

!

!

ip multicast-routing

no ftp-server write-enable

!

!

!

!

interface FastEthernet0/0

description ***WAN Link Connect to Datacenter ***

ip address 192.168.1.2 255.255.255.252

duplex auto

speed auto

!

!

interface FastEthernet0/1

no ip address

duplex auto

speed auto

!

interface FastEthernet0/1.100

description *** BR-WAE ****

encapsulation dot1Q 100

ip address 10.10.10.2 255.255.255.0

ip wccp redirect exclude in

!

interface FastEthernet0/1.200

description **** Client PC ****

encapsulation dot1Q 200

ip address 20.20.20.2 255.255.255.0

ip wccp 61 redirect in

ip wccp 62 redirect out

!

ip classless

ip route 172.16.39.0 255.255.255.0 192.168.1.1

ip route 172.16.40.0 255.255.255.0 192.168.1.1

no ip http server

!

-----------------------------------------

Branch Switch

-------------

interface FastEthernet0/1

description *** WAE Appliance ***

switchport access vlan 100

switchport mode access

!

interface FastEthernet0/3

description *** Client PC ***

switchport access vlan 200

switchport mode access

!

interface FastEthernet0/4

!

interface FastEthernet0/5

description *** MGMT WAE ***

switchport access vlan 100

switchport mode access

!

interface FastEthernet0/8

description *** Connecting 1841 Router ***

switchport mode trunk

!

Regards,

ArunPrabhu A

New Member

Re: WAAS Critical Issue - Producing Outages

Please find the Branch WAE configuration.

Cisco Employee

Re: WAAS Critical Issue - Producing Outages

Arun,

I recommend that you choose between 4.1 or 4.0 for the software version you want to use. Then migrate ALL your devices to the same level of code. I would recommend making a decision between 4.1.1d or 4.0.21 as they are the latest in to code levels and contain the most code fixes. I don't recommend mixing major versions unless you are testing migration scenarios. If you are going to stay with the current levels of code on your accelerators, migrate your CM to the same 4.1 code you WAE is also running. That will also be backwards compatible to the 4.0.17 box. The 4.0.19 CM will continue to show the 4.0.17 box offline per my earlier note due to imcompatibility of CMS in 4.0 (see the release notes on cisco.com)

For short term testing, I would remove the following config from your 4.1 WAE:

directed-mode enable

That is not compatible with 4.0 WAEs.

I don't see anything else off the top from your configs, they all look pretty good. If the above recommendations don't help out, please include your redirect-list 110 (from the DC) and also the results of your "sh stat conn all" off both of the WAEs while you are seeing PT connections. We should see why you are getting PT connections from this command.

Dan

New Member

Re: WAAS Critical Issue - Producing Outages

Hi dan,

We are able to see the optimized traffic in both Datacenter WAE & Branch WAE. But we are facing the problem of Branch WAE (4.1 code) goes online and offline mode frequently. To fix this issue whether we need to upgrade the IOS version of Branch WAE to 4.0 ?.

If so Please could you provide the downgrade the IOS procedure document

Regards,

Pradeep

Cisco Employee

Re: WAAS Critical Issue - Producing Outages

Pradeep,

This can be found in the release notes for 4.1.1.

http://www.cisco.com/en/US/docs/app_ntwk_services/waas/waas/v411/release/notes/ws411rn.html#wp42174

You can also resolve your issue by upgrading your CM to 4.1.

Please note, in my previous post, in 4.0, your CM needs to be the OLDEST version. So either upgrade/downgrade all your boxes to the same version or upgrade the 4.0.17 box as well.

Hope that helps,

Dan

New Member

Re: WAAS Critical Issue - Producing Outages

Hi Dan,

As per your inputs we have promoted one of the WAE in ( 4.1 Version ) as Central Manager, and degraded the CM ( in 4.0 Version ) to WAE. And we have fixed the offline / online Problem.

The WAAS is now being integrated in the Customer Network and after observation of one day, All our traffic got optimized are showing under the catagory of other traffic in the graph ( like - Top 10 Applications ).

The configuration of Full optimazion is bounded to FTP,HTTP,MAPI and RAdmin.

Please clarify whether the usual copy and paste to and fro Branch and Central site will show under FTP traffic ?

Please suggest any other configuration required in WAAS box to display the specific application traffic in GUI.

Regards,

ArunPrabhu A

278
Views
0
Helpful
9
Replies
CreatePlease to create content