Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

WAAS Redirect Issues

I'm trying to setup a simple WAAS setup with a Manager, Core and Edge device. The core and edge devices are seperated across an MPLS cloud. The redirect is configured on the CE routers so I don't believe the MPLS is the problem.

The Manager can see both the Core and Edge devices but no acceleration is happening. When I check the wccp status on the core I see both LAN and WAN inetrfaces are redirecting packets but the edge router is only showing redirects on the LAN.

The edge router is a Cisco 2821 with a WAAS Services Module. The router is connected to the MPLS cloud by an ATM interface. (Config Below).

service timestamps debug datetime

service timestamps log datetime

service password-encryption

!

hostname xxxxxxxxxxx

!

boot-start-marker

boot-end-marker

!

logging buffered 10000 debugging

!

aaa new-model

!

!

aaa authentication login default group tacacs+ local

aaa authentication login conmethod group tacacs+ enable

aaa authentication enable default group tacacs+ enable

aaa authorization exec default group tacacs+ local

aaa authorization network default group tacacs+

aaa authorization network noauthor none

!

aaa session-id common

!

resource policy

!

clock timezone GMT 0

clock summer-time BST recurring last Sun Mar 2:00 last Sun Oct 2:00

ip wccp 61

ip wccp 62

ip telnet source-interface GigabitEthernet0/0

!

!

ip cef

!

interface Loopback0

description MPLS ATM Loopback Address

ip address 10.0.0.5 255.255.255.255

!

interface GigabitEthernet0/0

description London Corp LAN

ip address 53.253.7.250 255.255.255.0

ip access-group dealersubnets in

ip wccp 61 redirect in

duplex auto

speed auto

!

interface ATM0/3/0

no ip address

no atm ilmi-keepalive

dsl operating-mode auto

!

interface ATM0/3/0.1 point-to-point

description MPLS WAN

bandwidth 2000

ip unnumbered Loopback0

ip wccp 62 redirect in

no snmp trap link-status

pvc 0/38

vbr-nrt 248 248

encapsulation aal5mux ppp Virtual-Template100

!

!

interface Integrated-Service-Engine1/0

ip address 192.168.1.9 255.255.255.252

ip wccp redirect exclude in

service-module ip address 192.168.1.10 255.255.255.252

service-module ip default-gateway 192.168.1.9

no keepalive

!

interface Virtual-Template100

ip unnumbered Loopback0

no peer default ip address

!

router bgp 64527

no synchronization

bgp log-neighbor-changes

network 10.0.0.5 mask 255.255.255.255

network 53.253.7.0 mask 255.255.255.0

network 192.168.1.8 mask 255.255.255.252

neighbor x.x.x.x remote-as 2856

neighbor x.x.x.x ebgp-multihop 3

neighbor x.x.x.x update-source Loopback0

no auto-summary

!

ip route 0.0.0.0 0.0.0.0 x.x.x.x

!

!

no ip http server

no ip http secure-server

ip tacacs source-interface GigabitEthernet0/0

!

!

access-list 120 permit tcp any any log

If anyone can help me with this I would be most greatful as I need to get WAAS working ASAP.

The IOS version is c2800nm-spservicesk9-mz.124-9.T2.bin and the WAAS module is running 4.0.3.b.9

Thanks

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: WAAS Redirect Issues

With the virtual template in there, redirection is not supported. So, had to the redirection on a physical interface. Watch your router's CPU for problems and enjoy the optimization!

3 REPLIES
Cisco Employee

Re: WAAS Redirect Issues

Try adding the command of: ip wccp redirect exclude in on the integrated service module and then take 62 in off the atm interface and apply ip wccp 62 out to the LAN interface.

New Member

Re: WAAS Redirect Issues

I have implemented the above config and the wccp redirect on tcp 61 and 62 is now working. WAAS is now seeing traffic and optimising.

Why do you think that wccp want work on the atm interface?

Cisco Employee

Re: WAAS Redirect Issues

With the virtual template in there, redirection is not supported. So, had to the redirection on a physical interface. Watch your router's CPU for problems and enjoy the optimization!

194
Views
0
Helpful
3
Replies
CreatePlease to create content