Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Anonymous
N/A

WCCP Redirection not happening on 3750

I have a problem with WCCP redirection on a 3750 switch. hardware and IOS versions are listed as supporting WCCPv2. WAE configured at a core site and at the remote site. "ip wccp 62 redirect in" configured on the interfaces at each end connected to the WAN link. A WAE is directly connected to the WCCP switch at each end. Traffic is successfully being optimised when ssh to the remote site WAE itself (can see in sh tfo conn summ) but traffic coming from remote site clients does not appear to be getting redirected at the remote site. "ip wccp 61 redirect in" configured on vlan int didn't work and also have tried setting up the int as L3 and configured the same on physical int but still not redirecting. Looks like the traffic from the client IS being redirected at core site though, since we are seeing the traffic in "show tfo conn summ" on the core WAE but it is listed under pass through. Also getting PT no peer for this traffic. Nothing showing up from clients on the remote site WAE unfortunately.

If anyone has some ideas on how to resolve this please advise.

2 REPLIES
Cisco Employee

Re: WCCP Redirection not happening on 3750

David,

What version of IOS are you running on the 3750? You should also make sure the WAE is configured for l2-redirect and mask-assign, which are required by the 3750. Finally, which SDM are you running on the 3750? The 3750 requires an SDM that supports PBR for WCCP to work properly.

Thanks,

Zach

Anonymous
N/A

Re: WCCP Redirection not happening on 3750

Thanks Zach,

double checked my configs and found it was hash instead of mask. now all working OK...

Takes a little time to negotiate before the services become "usable" and even when you set it to hash it still comes up as usable so was a bit misleading. We were also using wrong SDM template (which I noticed yesterday in the logging and fixed).

cheers for the quick responses.

335
Views
0
Helpful
2
Replies
CreatePlease to create content