Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

WCCP Router config

I found this paragraph in the IOS 12.x documentation. The second sentence seems odd to me. Because WCCP redirection was enabled on a specific interface, it affects all interfaces on a router. Does it only affect interfaces that have an outbound redirection statement associated with them or does it affect all traffic on all interfaces?

Configuring WCCP for redirection for inbound traffic on interfaces allows you to avoid the overhead associated with CEF forwarding for outbound traffic. Setting an output feature on any interface results in the slower switching path of the feature being taken by all packets arriving at all interfaces. Setting an input feature on an interface results in only those packets arriving at that interface taking the configured feature path; packets arriving at other interfaces will use the faster default path. Configuring WCCP for inbound traffic also allows packets to be classified before the routing table lookup, which translates into faster redirection of packets.

  • Application Networking
2 REPLIES

Re: WCCP Router config

Often times complex troubleshooting issues are best addressed in an interactive session with one of our trained technical assistance engineers. While other forum users may be able to help, it’s often difficult to do so for this type of issue.

To utilize the resources at our Technical Assistance Center, please visit http://www.cisco.com/tac and to open a case with one of our TAC engineers, visit http://www.cisco.com/tac/caseopen

If anyone else in the forum has some advice, please reply to this thread.

Thank you for posting.

Anonymous
N/A

Re: WCCP Router config

Has anyone tried configuring a Cisco 2621 with NAT/CBAC/CEF/WCCP simultaneously? I have a branch office connection with a single router and am having serious trouble getting CBAC and WCCP to work nicely together. I'm redirecting to a Volera Cache Engine. Synopsis of config:

ip wccp web-cache redirect-list http

ip wccp 98 redirect-list streams

ip cef

ip inspect audit-trail

ip inspect name filter cuseeme

ip inspect name filter ftp

ip inspect name filter h323

ip inspect name filter http java-list 90

ip inspect name filter netshow

ip inspect name filter realaudio

ip inspect name filter rtsp

ip inspect name filter streamworks

ip inspect name filter tcp

ip inspect name filter udp

ip inspect name filter vdolive

ip audit notify log

interface FastEthernet0/0

ip address 10.32.2.1 255.255.255.0

ip nat inside

ip wccp web-cache redirect in

ip wccp 98 redirect in

interface Serial0/0.100 point-to-point

ip address 100.100.100.217 255.255.255.252

ip access-group 101 in

ip nat outside

ip inspect filter out

interface FastEthernet0/1

ip address 32.100.100.241 255.255.255.248

ip nat pool office-net 32.100.100.245 32.104.73.246 netmask 255.255.255.248

ip nat inside source list 99 pool office-net overload

ip access-list extended http

permit tcp any any eq www

ip access-list extended streams

permit tcp any any eq 1755

permit udp any any eq 1755

permit udp any any eq 554

permit tcp any any eq 554

access-list 90 permit any

access-list 99 permit any

access-list 101 permit (all my vpn tunnel entries)

access-list 101 permit (certain icmp)

access-list 101 deny ip any any log

180
Views
0
Helpful
2
Replies
This widget could not be displayed.