Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

WCCP with 3560

I have configured a 3560 (122-44 IP Services) switch to communicate WCCP with an WAE-612 v4.1. However the devices don't form WCCP server-client relation with each other.

When I enable "debug wccp all" on the WAE: It complains with:

"2008 Sep 17 13:54:49 CCI-WC-NC-01 wccp: %WAAS-DDBG-7-899998: ISU assignment capability 2

2008 Sep 17 13:54:49 CCI-WC-NC-01 wccp: %WAAS-DDBG-7-899998: wccp2.c:3169:

2008 Sep 17 13:54:49 CCI-WC-NC-01 wccp: %WAAS-DDBG-7-899998: Router cannot support configured capability for assignment method."

WAE-612 is directly connected to the switch through a vlan. I tried GRE and L2 forwarding methods.

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: WCCP with 3560

3560/3750 should use the following configurations guidelines...

1. Ingress interception (redirect out isn't supported.

2. Layer 2 redirect

3. Layer 2 return is supported (and preferred)

4. Mask assign (default of hashing is not supported)

5. WAE must be L2 adjacent, no L3 hops.

Hope that helps,

Dan

5 REPLIES
Community Member

Re: WCCP with 3560

Can you post the configuration for the wccp router-list on the wae and the wccp configurations from the switch? It look like you are using mask assignment when you should be using hash or vice versa.

Community Member

Re: WCCP with 3560

the wae config and wccp output:

CCI-WC-NC-01#sh run | i wccp

wccp router-list 8 192.168.192.33

wccp tcp-promiscuous router-list-num 8 l2-redirect assign-method-strict l2-return

wccp version 2

CCI-WC-NC-01#sh wccp router

Router Information for Service: TCP Promiscuous 61

Routers Configured and Seeing this Wide Area Engine(0)

-NONE-

Routers not Seeing this Wide Area Engine

192.168.192.33

Routers Notified of but not Configured

-NONE-

Multicast Addresses Configured

-NONE-

Router Information for Service: TCP Promiscuous 62

Routers Configured and Seeing this Wide Area Engine(0)

-NONE-

Routers not Seeing this Wide Area Engine

192.168.192.33

Routers Notified of but not Configured

-NONE-

Multicast Addresses Configured

-NONE-

3560 config and wccp outputs:

CCI-SW-NC-BB-01#sh run | i ip wccp

ip wccp 61 redirect-list 101

ip wccp 62 redirect-list 102

CCI-SW-NC-BB-01#sh ip wccp

Global WCCP information:

Router information:

Router Identifier: 192.168.192.254

Protocol Version: 2.0

Service Identifier: 61

Number of Service Group Clients: 0

Number of Service Group Routers: 0

Total Packets s/w Redirected: 0

Process: 0

CEF: 0

Redirect access-list: 101

Total Packets Denied Redirect: 0

Total Packets Unassigned: 0

Group access-list: -none-

Total Messages Denied to Group: 0

Total Authentication failures: 0

Total Bypassed Packets Received: 0

Service Identifier: 62

Number of Service Group Clients: 0

Number of Service Group Routers: 0

Total Packets s/w Redirected: 0

Process: 0

CEF: 0

Redirect access-list: 102

Total Packets Denied Redirect: 0

Total Packets Unassigned: 0

Group access-list: -none-

Total Messages Denied to Group: 0

Total Authentication failures: 0

Total Bypassed Packets Received: 0

thanks

Cisco Employee

Re: WCCP with 3560

you need to add the mask-assign statement to your WAE config. The 3650 doesn't support hash-assign (default). See my other response.

Dan

Cisco Employee

Re: WCCP with 3560

3560/3750 should use the following configurations guidelines...

1. Ingress interception (redirect out isn't supported.

2. Layer 2 redirect

3. Layer 2 return is supported (and preferred)

4. Mask assign (default of hashing is not supported)

5. WAE must be L2 adjacent, no L3 hops.

Hope that helps,

Dan

Community Member

Re: WCCP with 3560

Thanks Dan,

Mask assignment solved my problem.

Bulent

876
Views
0
Helpful
5
Replies
CreatePlease to create content