Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

1/2 Ring was heard when calling an extension configured on SPA232D/ SPA302D

Hi,

We have setup an office IP pBX system, the phones being used are SPA303, SPA504, and SPA232D/ SPA302D.

whenever we call the extension configured on SPA232D/ SPA302D, we could just hear 1/2 ring then silence on the phone that was used to call the SPA232D/SPA302D. We would need to reboot or set to factory default SPA232D/SPA302D for it to work. But after some time, we would hear 1/2 ring then silence again when calling SPA232D/SPA302D.

Any thoughts why were having this kind of issue on SPA232D?SPA302D?

Any idea on how we can resolve this issue?

 

thanks in advance,

4 REPLIES
VIP Gold

No one reported as far as I

No one reported as far as I know. I assume you are using latest firmwares on all Cisco devices you mentioned.

 

Turn on syslog&debug and catch them. Catch SIP dialog packets as well. It will help us with further analysis.

 

Installing and Using Wireshark for Capturing Network Traffic

Debug and syslog Messages from SPA1x2 and SPA232D ATA (Analog Telephone Adapters)

New Member

Hi Dan,Thank you for your

Hi Dan,

Thank you for your response.

it seems we're the 1st one if not the only one who experience this issue when calling an extension configured on SPA232D/SPA302D.

I will follow your advice, and will update you as soon as i finished collecting data.

 

If i may ask, is this issue coming from the SPA232D/SPA302D itself or something else?

i have read something about this issue, sorry i forgot the URL, saying that it's something about the ringback tone script. Though not clear to me if there's an issue with the ringback tone script of the called telephone(SPA232D/SPA302D) or the telephone (Ex. SPA303) used to call SPA232D/SPA302D. Any enlightenment on this matter is very much appreciated.

 

Many thanks,

VIP Gold

is this issue coming from the

is this issue coming from the SPA232D/SPA302D itself or something else?

It why I'm asking you to catch the data. I hope they will allow to answer the question.

 

Well, some background. Ringback tone can be generated either locally (by calling phone) or may be transfered as inband audio signal from any device on the path. In the first case, the ringback tone script on calling device (SPA303) needs to be taken into consideration. In the second case, it's not relevant as SPA303 is not source of ringback.

To make task more complex, not only calling and called needs to be taken into consideration, but all switches on the path as well. SPA232D (as called device) will never use inband ringback. It respond with 180 message all the times (180 mean "play local ringback tone to caller"). But any switch on the path may replace such mesage with 183 message claiming "just listen, I'm sending inband ringback to you").

Even worse, in complex environment there may be more than one 18x response.

So I need to see the response to INVITE. It allow us to identify source of ringback tone.

 

New Member

Hi Dan,Thank you very much

Hi Dan,

Thank you very much for explaining to me the thing about ringback tone. that greatly helps newbies like me to understand things. appreciate it very much.

I will follow your advice, and will update you as soon as i have collected the necessary data.

 

thank you vey much,

66
Views
0
Helpful
4
Replies
CreatePlease to create content