Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Auto-Dial delay with SPA122

I have an auto-offhook (Plar, Hot-Line) configuration set up on my ATA 122.  When I take the phone off-hook the ATA takes 3 seconds to place the call to the network.

 

My dial-plan entry is as follows:

<Dial_Plan_1_>( P0 <:4802788500>)</Dial_Plan_1_>

 

I've captured debugging level syslog from the ATA during the process.

 

*** I go off-hook and the following is generated right away (all within 100 msec) ***

 

[0]Off Hook

CC_eventProc(), event: CC_EV_USR_OFFHOOK(0x2), lid: 0, par: 0, par2: (nil)

AUD_ccEventProc: event 2 vid 0 par 0x0 par2 0x0

sysstatus_set_led_status_payton(), led_id: 1, statusCode:7, systemEvent: 0x100095

[IVR_eventProc] evt 2 lid 0

callEventProcTable[0] is cepIdleProc

cepIdleProc(line=0x1f90e8, call=0x1f90ec, event=9(CC_EV_USR_SEIZURE), par=0, par2=(nil))

cepIdleProc(), lid=0

cepIdleProc(), pname=proxy.adam.tnltd.net

cepIdleProc(), SYS_NOREG_CALL(0)=0, SIP_REGISTER_OK(0)=1

[AUD]Get UCH node for AUD_LINE 0 0.

uchAllocateNode(), Node 0 allocated

[AUD]UCH node 0 allocated to AUD_LINE 0.

uchConnectEpToNode(), connecting EP FXS 1 to node 0

uchEnableNode(), Node 0 enbaled

NEW_CALL_STATE(), call 0: old state = CC_CST_IDLE, new state CC_CST_DIALING

SLIC_stopRing

SLIC_startTone 1

uchSetMute(), ENABLE

 

*** There is then a 2.5 second pause ***

 

Set QoS succeed

callEventProcTable[1] is cepDialingProc

 

(The call is placed).

 

There is a 2.5 second pause between the "uchSetMute(), ENABLE" and the "Set QoS succeed".

 

Anyone have any ideas why the ATA is sitting there for so long before the call is placed?

 

Thanks

-Adam

Everyone's tags (5)
1 ACCEPTED SOLUTION

Accepted Solutions

Auto-Dial delay with SPA122

It could be the Interdigit short timer, the default value is 3 seconds. Do you have already tried to reduce this value?

Regards.

2 REPLIES

Auto-Dial delay with SPA122

It could be the Interdigit short timer, the default value is 3 seconds. Do you have already tried to reduce this value?

Regards.

New Member

Auto-Dial delay with SPA122

Daniele,

That was it, thanks!

-Adam

2650
Views
0
Helpful
2
Replies
CreatePlease login to create content