Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

CISCO IP Phone 7945 in upgrading status

Hi 
 
Good day! May I request for technical assistance on the CISCO 7945 IP Phones that are in upgrading status of firmware, but it shows an error and doesn't proceed with upgrading.
 
I tried to do factory settings on the IP Phone by pressing 123456789*0# but it doesn't work. I tried to contact our service provider but they could not offer another solution to this aside from resetting the factory settings. We already have several IP Phones with the same problem. I hope you could assist me on this, thanks
8 REPLIES
Cisco Employee

Hi April,

Hi April,

1. Enable Spanning on the switch and capture the packet capture and see if you can find any DHCP from the phone.
2. Check what IP phone is getting from DHCP. Verfiy if it is correct. (IP,Mask,Gateway,TFTP servers)
3. Check whether phone is communicating with TFTP server or not. (filtering the packet capture with TFTP address)
4. Change TFTP trace level to detailed in CUCM serviceability (assuming you are using CUCM) and see if you are getting any request from the phone.

Regards,

Sudheer Shenoy

New Member

Hi

Hi

Thanks for replying to my post.  We could not set the DHCP and the TFTP server. This is usually found by pressing the settings button of the CISCO 7945 IP phone and editing the IPv4 Configuration, but I could not access the settings of the IP Phone. The phone seems to be stock in this upgrading status. I attached the photo on what the phone looks like. 

We now have 3 IP Phones with the same problem. I hope you can assist me on this. thanks

On the switch the phones are

On the switch the phones are connected to, do a "sh cdp nei detail" to see if the phones have an IP address, looks like they are not communicating with the CUCM

New Member

ok, tnx sir. what steps

ok, tnx sir. what steps should be done for the IP Phones to be able to communicate to the CUCM?

Have the IP phones got an IP

Have the IP phones got an IP address? did you do a sh cdp nei detail on the switch the phones are connected to, this tells you if they have an IP address. If not then the dhcp configuration has to be checked. Where do the phones get their IP address? is it the switch?

please share the configuration of the switch the phones are connected to, and the DHCP server if not on the switch.

please note the DHCP server should have option 150 set with the IP address of the CUCM TFTP server.

New Member

Plug your device in to power

  1. Plug your device in to power and connect to the Internet with Wi-Fi.
  2. Tap Settings > General > Software Update.
  3. Tap Download and Install. If a message asks to temporarily remove apps because iOS needs more space for the update, tap Continue or Cancel. Later, iOS will reinstall apps that it removed. If you tap Cancel,learn what to do next.
  4. To update now, tap Install. Or you can tap Later and choose Install Tonight or Remind Me Later. If you tap Install Tonight, just plug your iOS device in to power before you go to sleep. Overnight, your device will update automatically.
  5. If asked, enter your passcode.

New Member

I would suggest that you get

I would suggest that you get a tftp server like tftpd32. Install it on your laptop. Next download the firmware for the 7945 phone to the tftp server directory. Then configure a seperate vlan and dhcp scope for this phone. Assign the pc ip where your tftp server is installed as the tftp ip. Then power cycle the phone. Observe what request the phone is sending to the tftp server...That will give you an idea of what's going on...99 percent of the reason why the phone shows a blank screen or upgrading screen is because its unable to contact its tfp server and/or find the firmware.

If you have administrative rights to the network switch/router you could perform the above by configuring DHCP server and pool on the local router and server the firmware files for the phone to be downloaded.

Once the phone has the correct firmware and back up and you can access setting, you can then input and configure it back to normal.

There are plenty of blogs and youtube videos on "how to un-brick cisco IP" phone or "fix blank or upgrading screen"

New Member

you need to install TFTP

you need to install TFTP Server in you laptop or PC such as TFTP64.exe. In that TFTP upload firmware that you need. Create a DHCP scope for IP phones and add option 150 to IP Tftp Server.

Put you IP phones in this vlan and observe that ip phone is downloading the firmware from TFTP server (Tftp64.exe or tftp32).

Regards,

Charles

358
Views
5
Helpful
8
Replies
CreatePlease to create content