Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

SPA 112 Phone or Web access

Somebody hacked my SP112 and I was advised to chenge WAN access to desable. I did that and now I am unable to access it. I tried to use a phone to change the remote access parameter (action 7932#) but after entering # I get a message "invalid option". Now I am stuck. Current firmware is 1.3.3015. Any solution how to change this parameter by phone?

 

Thanks

Milosh

Everyone's tags (1)
15 REPLIES
New Member

Did you try to "reset to

Did you try to "reset to default" by using the "Reset" button or one of the two other methods?

Before you do, save or note the current settings.

http://blog.voipdiy.com/2013/02/cisco-spa112-how-to-restore-to-factory.html

New Member

Hi Jos,I didn't try that. I

Hi Jos,

I didn't try that. I left it as a last solution. Last is because I have no other options, and I can not access the data I set in to make a note or to make a backup.

It is very strange that I can not change remote access settings by phone. Have no idea why I get message invalid option. Other codes entered by phone work ok. What could be the reason that this code 7932 doesn't work?

 

Milosh

New Member

I have no idea why the code

I have no idea why the code 7932 doesn't work.

VIP Gold

Because the intruder disabled

Because the intruder disabled access to it ? Or the device in question is OEM/restricted unit, so there has been no access to such kind of configuration at all ?

We know so little details about the case ...

New Member

The intruder didn't disable

The intruder didn't disable it. I did it.  I connected to SP112 as usually by LAN and disable it. I was adviced by a VOIP provider to do so. Then I tried to access by phone to enable it again, but got the message that option is invalid. Is there any other way to disable phone option 7932?

Dan, what do you mean by OEM/restricted unit. I purchased unit in Tiger Direct. How can I check if it is restricted?

VIP Gold

You asked "What could be the

You asked "What could be the reason that this code 7932 doesn't work?" so I didn't expected that you disabled it. You can reset the device to factory default to restore device settings. As long as you are not intruder but authorized administrator of the device in question the reset has little or no disadvantages.

The restricted unit is unit customized for particular telco operator. There are forced restriction on it according particular operator wishes. Some options may not be avaiable for you or you may be allowed to login as administrator at all. You need to restore your access to WWW first.  Then open "Info" tab and search for option named "Customization" here. Unless there's "Open" state claimed you are lucky owner of OEM/restricted unit. 

New Member

Dan thanks for clarification

Dan thanks for clarification.

I understand that I can do reset to the factory default. I will do it as a last option, because in that case I have to enter all settings and I'd like to avoid that. It is possible to be done, but I'd really like to avoid that. If there is no other option, let's say I do it, and change all necessary setting to work with my telco operator, and then I disable web access again, and again, I am not able to enable it by phone. So it means that whenever I want to change something I have to reset it to factory default, reload my settings and then change whatever I want to change, and then disable web access again. This is pretty strange process, I'd say, but if there is no other option, I will do it.

The unit is in my home and I am the owner of ATA. I wouldn't say that the unit is restricted, because I purcased it in the store and the unit has nothing to do with telco operator.

New Member

Hi digger2antennaAfter you

Hi

Graphical user interface

 

New Member

Hi MohI will reset my ATA box

Hi Moh

I will reset my ATA box and this is the last solution, if there is not any other. Proxy user name and password - do you mean standard one I've got with the unit, when I want to log in via GUI, as admin?

 

Thanks

Milosh
 

New Member

HI Milosh, Porxy is phone

HI Milosh,

 

Porxy is phone provider server IP/or URL

username and password your account access

example: you want access your gmail email, all you need gmail.com URL and your account username and password, correct?

same thing with SPA122 or SPA112 you need to let unit phone provider IP/or URL and your account.  so don't reset unit until you get this info from phone company.

 

Thanks,

Moh

New Member

HI MohYes I know my proxy IP

HI Moh

Yes I know my proxy IP/URL because the unit was working for a more than a year. and for that time I accessed it via GUI. Had no problem. But now, I don't see a way to enable web access via phone. Do you have any idea how to do that without resetting to factory default and start from the scratch?

 

Thanks,

Milosh

New Member

Hi Milosh, I did try bridge

Hi Milosh,

 

I did try bridge my own ATA and I did try access to it and I can't.  However you can give Cisco center phone call and maybe after lab it we fine different way to access this unit.  our phone number is 1-866-606-1866

 

Thanks,

Moh

New Member

Thanks Moh,I will call them

Thanks Moh,

I will call them.

Milosh

New Member

FW1.3.5IVR not work correctly

FW1.3.5

IVR not work correctly!

100 - Not work
101 - Work, but have no any effects after reboot
111 - Invalid option with any sets in 101
7932 - Invalid option

I'm angry!

Without admin web access helps only factory reset, only HARDCORE!

Without dhcp server in your network helps nothing!

VIP Gold

I can't confirm in full.

I can't confirm in full. Tried just now on SPA112 / 1.3.5(004):

 

The "100" works for me.

"111" works for me as long as 100 is set to 1, but the settings doesn't survive reboot (which is forced on hangup).

7932 is obviously invalid - the 'RWEB' option is related to access via WAN port, but there's no one WAN port on SPA112

 

See also (related): IVR Codes, Discussion Cisco SPA232D "Internet Settings" loses Static IP configiuratoin & "Time Settings" on Reboot

996
Views
0
Helpful
15
Replies
CreatePlease to create content