Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

spa112 - cannot answer inbound calls

Hi,

I have an adapter which has an odd issue with not being able to answer an incoming call. Outbound is clear quality and working great on both line-1 and line2.

SCENARIO:

Inbound call comes from provider, phone rings and displays caller-ID. I answer the phone but do not hear anything, only my own voice echoing back "Hello?" "Hello?". The caller simply hears ringing tone and call goes to voicemail. As though the device is not sending any reply that I have answered the call.

Tests:

I have this device with provisioning on. It was using SPA122_1.3.1_003 firmware when this started happening (this issue just started a few days ago). It is now upgraded and using the latest SPA122_1.3.2-XU firmware. I've tested both line-1 and line-2 to confirm the same results. I have tried to downgrade to  with same results.

Anyone know what I can try next to troubleshoot this problem?

Thanks,

Sean

4 REPLIES
New Member

spa112 - cannot answer inbound calls

Sounds like a NAT issue.

You can verify by running debug log.

Config for logging at

https://supportforums.cisco.com/docs/DOC-9862

https://supportforums.cisco.com/docs/DOC-26697

New Member

spa112 - cannot answer inbound calls

Hi,

I checked with the provider. They confirmed the proper settings user/pass etc with me and that is ok. They say that the device replies to the initial INVITE with 183 RINGING, but no further message is sent therefore the call timeout is reached on the provider side and the call goes to voicemail on the provider system.

However, I am picking up the phone on the first or second ring.

So even if I pick up the phone, the device is not sending any message to the provider indicating that I answered the call. That said, no SDP is being negotiated even. So NAT would not be the problem.

Outbound is 100% perfect, no issues at all and excellent call quality.

Any other ideas?

New Member

spa112 - cannot answer inbound calls

You'll need to run a debug log to see what the unit is sending.  Normally in response to Invite, it sends 100 Trying, 180 Ringing and then 200 OK.  Then the other side sends ACK and then audio occurs.

Hall of Fame Super Gold

spa112 - cannot answer inbound calls

Check with your Voice provider and verify you've entered the Inbound Proxy details correctly.

693
Views
0
Helpful
4
Replies