Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

SPA112 Scripted Reboot

Does anyone know a command line script that can periodically soft reboot the SPA112?

 

Firmware 1.2.1 still hasn't fixed the uptime issues and the unit reguarly locks up after 2-3 days with no dial tones and response to web admin requests.

 

You then need to hard reset the unit by pulling the power cable and replugging again.

 

Tried using the following command:

 

http://spa112ip/reboot&xuser=username&xpassword=password

 

but receive a "405 Method Not Allowed!" error.

 

Tried using Curl but there are ASP session ID's for the login and Javscript prompts when hitting the Reboot page directly:

 

http://spa112ip/Reboot.asp

 

Thanks

Everyone's tags (2)
7 REPLIES
New Member

SPA112 Scripted Reboot

Since you are having regular lock ups, can you send a debug log of this?  I'd like to get a developer to take a look at the log to see what's happening.

Logging details at https://supportforums.cisco.com/docs/DOC-9862

New Member

SPA112 Scripted Reboot

We started having this issue as soon as we started using 1.2.1  We had about 20 with this problem in the field out of 20

I have reverted back to 1.1.0

New Member

SPA112 Scripted Reboot

Can you get a log of this?  We need to get at the bottom of this problem.  Thanks.

New Member

SPA112 Scripted Reboot

I like my customers too much to run known buggy code.  I will try in my lab but I have not seen this issue.  I only see the devices unregistered and when I plugged in a phone they re register

New Member

SPA112 Scripted Reboot

I just noticed.  You need admin before reboot so

Http://(ip)/admin/reboot

Also you can try wget

New Member

Re: SPA112 Scripted Reboot

I've tried evrything in this thread with no luck.

Sending SIP NOTIFY "reboot" and "restart" commands seems to work, but device hangs up anyway.

The only working method I found is sending command via web interface. You can script this via Perl (see attachment).

Cisco Employee

SPA112 Scripted Reboot

This appears to be related to https://supportforums.cisco.com/message/3779434#3779434

Regards,

Patrick

----------

2337
Views
10
Helpful
7
Replies
CreatePlease login to create content