Cisco Support Community
Community Member

Does Cisco 7600 Support QPPB with QoS?


The BGP routes can successful marks an IP precedence values by QPPB. But the QoS seems is not working when match the IP precedence. 

Any help is much appreciated!


class-map match-all Prec-3

 match access-group 20

 match precedence 5

class-map match-all allow

 match access-group 20


policy-map Meter

 class Prec-3

 class allow


interface GigabitEthernet9/0/0

 ip address

 media-type rj45

 speed 1000

 no negotiation auto

 bgp-policy destination ip-prec-map


interface GigabitEthernet9/0/1

 ip address

 media-type rj45

 speed 1000

 no negotiation auto

 service-policy output Meter


router bgp 100

 table-map QPPB

 bgp log-neighbor-changes


 neighbor remote-as 200


ip forward-protocol nd


ip as-path access-list 100 permit 200$

access-list 20 permit


route-map QPPB permit 10

 match as-path 100

 set ip precedence critical



Router# show ip bgp

BGP table version is 3, local router ID is

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,

              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,

              x best-external, a additional-path, c RIB-compressed,

Origin codes: i - IGP, e - EGP, ? - incomplete

RPKI validation codes: V valid, I invalid, N Not found


     Network          Next Hop            Metric LocPrf Weight Path

 *>               0             0 200 i

 *>                  0         32768 i


Router#show ip route

Routing entry for

  Known via "bgp 100", distance 20, metric 0

  Tag 200, precedence critical (5), type external

  Last update from 1d06h ago

  Routing Descriptor Blocks:

  *, from, 1d06h ago

      Route metric is 0, traffic share count is 1

      AS Hops 1

      Route tag 200

      MPLS label: none


Router#show policy-map interface



  Service-policy output: Meter


  Counters last updated 00:00:01 ago


    Class-map: Prec-3 (match-all) 

      0 packets, 0 bytes

      5 minute offered rate 0000 bps

      Match: access-group 20

      Match:  precedence 5


    Class-map: allow (match-all) 

      0 packets, 0 bytes

      5 minute offered rate 0000 bps

      Match: access-group 20


    Class-map: class-default (match-any) 

      3908 packets, 261198 bytes

      5 minute offered rate 0000 bps, drop rate 0000 bps

      Match: any


CreatePlease to create content